Bug 498144 - anaconda F11 issue
anaconda F11 issue
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
anaconda_trace_hash:ced9659aa97e8a4db...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 00:40 EDT by Parag Nemade
Modified: 2009-08-07 13:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-29 04:56:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (82.11 KB, text/plain)
2009-04-29 00:40 EDT, Parag Nemade
no flags Details
Attached traceback automatically from anaconda. (94.14 KB, text/plain)
2009-08-07 13:23 EDT, Christoph van der Reijden
no flags Details

  None (edit)
Description Parag Nemade 2009-04-29 00:40:33 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 162, in commitToDevice
    return self.__disk.commit_to_dev()
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 152, in commit
    if not self.commitToDevice():
  File "/usr/lib/anaconda/storage/devices.py", line 808, in commit
    self.partedDisk.commit()
  File "/usr/lib/anaconda/storage/devices.py", line 1157, in create
    self.disk.commit()
  File "/usr/lib/anaconda/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 659, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 234, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
IOException: Input/output error during write on /dev/sda
Comment 1 Parag Nemade 2009-04-29 00:40:43 EDT
Created attachment 341701 [details]
Attached traceback automatically from anaconda.
Comment 2 Parag Nemade 2009-04-29 02:15:30 EDT
I am doing this on F10 with kvm
kernel-2.6.27.19-170.2.35.fc10.i686
virt-manager-0.6.0-5.fc10.i386
Comment 3 Chris Lumens 2009-04-29 09:56:05 EDT
This is not a bug with anaconda.  You have a ton of error messages like the following in your exception report:

<3>ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
<3>ata1.00: cmd ca/00:01:00:00:00/00:00:00:00:00/e0 tag 0 dma 512 out
<3>         res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
<3>ata1.00: status: { DRDY }
<4>ata1: link is slow to respond, please be patient (ready=0)
<4>ata1: device not ready (errno=-16), forcing hardreset
<6>ata1: soft resetting link
<6>ata1.00: configured for MWDMA2
<6>ata1: EH complete
Comment 4 Bug Zapper 2009-06-09 10:45:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Leslie Satenstein 2009-06-10 22:39:57 EDT
Fedora 11 beta and Fedora 11 release.  

Anaconda crashes solidly, not allowing a trace back. Cannot do an installation­.

On this system, Fedora10 anaconda works fine, as does installation of Ubuntu and XP.  

Fedora11 beta and Fedora11 release crashes on this system and does not allow saving the traceback, or copying the traceback to a file.

The mother board is an asus P5Q, System Memory 4 gigs, sata device 250gigs,
intel e7300 dual core cpu.

Repeat, all previous versions of Fedora install fine on this system. That includes IDE and Sata.
Comment 6 Leslie Satenstein 2009-06-10 22:47:32 EDT
Further comments.  Tried the 386-F11 version after the x64-f11 version failed to load.

All dvds tested clean.  There is a real problem for me. I cannot install F11 on this system. I tried with vesa driver and all variations. 

Graphics card is a ATI hd3450, but that should not make a difference.

The F11 Beta version (dated day of beta release), on this system crashes and locks up too.

Leslie

PS. I have a second system (different motherboard (intel d95gnt -video integrated, 4 gigs, 300g hard disk), and the F11 beta is just fine. So, is it something with the bios, or annaconda.  (If it was the bios, why would the other systems boot, as well as live cds.
Comment 7 Alex Tunc 2009-06-17 21:55:47 EDT
I can confirm I cant install F11 via preupgrade on my laptop with ATI X200 onboard gfx.. anaconda doesnt start just freezed..
Comment 8 Leslie Satenstein 2009-06-18 22:02:02 EDT
Here is what I noted for my two problems. a) Gparted had been used to create a /boot (1g ext3), a swap (8gig) and a / (ext4 for 80gigs).  

I managed, when anaconda locked up, to query the virtual terminal, and I was able to determine that anaconda was looking for the lvm implementation.

So... I deleted /boot, /swap and /   and then from within anaconda, (which now did not crash), I reallocated /boot, /swap and /.  I did not bother to make a separate /home.

Anaconda has problems with the presence of pre-allocated directories when there is no lvm

F11 is up and running on the p5q system.
Comment 9 Leslie Satenstein 2009-07-28 21:06:22 EDT
Is this being addressed for Fedora 12?
Comment 10 Parag Nemade 2009-07-29 04:56:57 EDT
Assuming kernel-maintainers are very busy (as no comment received on this bug from them) and I am now running successfully F-11 final release, I would like to close this bug.
Comment 11 Christoph van der Reijden 2009-08-07 13:23:36 EDT
Created attachment 356689 [details]
Attached traceback automatically from anaconda.
Comment 12 Christoph van der Reijden 2009-08-07 13:49:51 EDT
Installation of Fedora11 from DVD i386 failed. Failure occurred during the installation while writing storage configuration to disk. A window "Storage Activation Falied" holds the message: An error was encountered while activating your storage configuration. Details: Input/output error during write on /dev/sda. The created attachement (id=356689) to this comment was filed automatically and sent to this (498144) bug report.

What would you suggest me to proceed to install Fedora11 successfully?

Note You need to log in before you can comment on or make changes to this bug.