Bug 498201 - PackageKit doesn't hook into xdg-open
PackageKit doesn't hook into xdg-open
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Holy
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 08:55 EDT by Mads Kiilerich
Modified: 2015-02-24 10:01 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-24 10:01:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2009-04-29 08:55:10 EDT
Description of problem:

The new PackageKit functionality for automatic installation of file handlers is nice.

But that it doesn't hook into xdg-open feels like a bug, even though it understandable and might be intentionally.


Version-Release number of selected component (if applicable):

PackageKit-0.4.6-8.fc11.i586
xdg-utils-1.0.2-8.20081121cvs.fc11.noarch


Steps to Reproduce:

[mk@localhost /]$ xdg-open /tmp/foo.doc 
Error showing url: No application is registered as handling this file

[mk@localhost /]$ xdg-open /tmp/
and double-clicking foo.doc works as expected
Comment 1 Richard Hughes 2009-04-29 12:46:16 EDT
Sure, if the XDG guys want this, then they are going to have to hook into PackageKit, not the other way around.
Comment 2 Rex Dieter 2009-04-29 12:56:45 EDT
I can try, I'll dig around for PK mime hook documentation (helpful pointers, hints appreciated).
Comment 3 Rex Dieter 2009-04-29 12:59:47 EDT
In particular, desktop-agnostic, non-gui hooks.

Else, we could try to fallback to desktop-specific methods (if they're available).
Comment 4 Rex Dieter 2009-04-29 13:09:20 EDT
ok, looks easy enough, use
gpk-install-mime-type <mimetype>
looks like a winner.
Comment 5 Bug Zapper 2009-06-09 10:46:55 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Steven M. Parrish 2009-07-21 20:58:07 EDT
Ping?  Any updates Rex?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Rex Dieter 2009-07-21 21:09:43 EDT
I think I understand what needs to be done, it's at the "waiting for sufficient round-tuits to implement" stage now.

Setting FutureFeature keyword, targeting rawhide.
Comment 8 Steven M. Parrish 2009-08-26 14:38:19 EDT
Ping   Still planning on having this in F12?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Rex Dieter 2009-08-26 14:45:33 EDT
Probabaly not in time for F12 myself, patches welcome and all that.
Comment 10 Rex Dieter 2009-12-17 14:36:34 EST
After thinking it over some.... I think I'm going to punt and let individual desktops handle this (gnome, kde, etc...).  xdg is too low-level methinks.
Comment 11 Mads Kiilerich 2009-12-17 15:47:30 EST
Well ... methinks PackageKit-command-not-found is even more low-level than xdg ;-)

Nobody objected to this being a reasonable expectation and feature request, so I will reassign to gvfs and gvfs-open.
Comment 12 Fedora Admin XMLRPC Client 2013-05-23 10:35:27 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 13 Ondrej Holy 2015-02-24 10:01:19 EST
It is an old bug and it seems to work in recent Fedora version correctly, so closing it. Feel free to reopen if it doesn't work for you...

Note You need to log in before you can comment on or make changes to this bug.