Bug 498202 - [abrt] crash detected in xfce4-xkb-plugin
[abrt] crash detected in xfce4-xkb-plugin
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xfce4-xkb-plugin (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:6651473989014dc2c2c9fcf6c94...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 08:57 EDT by Zdenek Prikryl
Modified: 2009-05-12 10:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 07:46:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Prikryl 2009-04-29 08:57:14 EDT
abrt detected crash.

How to reproduce
1. add keyboard switcher to xfce panel
2. Configuration window appears. In this window some parts are not filled (ie. keyboard model is blank, change layout option is blank, ...)
3. Click on "Close" button to confirm configuration
4. keyboard switcher ends with sigsegv

Commnet
Expected behavior is that error dialog pops-up and notify user or fill needed parts automatically.
Additional information
======
backtrace
-----
[New process 17291]
#0  0x065171da in IA__gtk_tree_model_get_valist (tree_model=0x88470c0, 
    iter=0x8052df4, var_args=0xbf82211c "P!\202\002")
    at gtktreemodel.c:1442
1442	      G_VALUE_LCOPY (&value, var_args, 0, &error);
#0  0x065171da in IA__gtk_tree_model_get_valist (tree_model=0x88470c0, 
    iter=0x8052df4, var_args=0xbf82211c "P!\202\002")
    at gtktreemodel.c:1442
	_vtable = (GTypeValueTable *) 0x11e903
	_lcopy_format = (gchar *) 0x7c2658 ""
	_cvalues = {{v_int = -1081990904, v_long = -1081990904, 
    v_int64 = 28875875797836040, v_double = 1.0051868584811125e-306, 
    v_pointer = 0xbf822108}, {v_int = 6725248, v_long = 6725248, 
    v_int64 = 614099749748252288, v_double = 1.3156649436071527e-267, 
    v_pointer = 0x669e80}, {v_int = -1081990936, v_long = -1081990936, 
    v_int64 = 28368283677892840, v_double = 9.2493603334073982e-307, 
    v_pointer = 0xbf8220e8}, {v_int = 6725248, v_long = 6725248, 
    v_int64 = 34937806613028480, v_double = 2.5031211759995406e-306, 
    v_pointer = 0x669e80}, {v_int = 134516268, v_long = 134516268, 
    v_int64 = 34945056645615148, v_double = 2.505413650900214e-306, 
    v_pointer = 0x8048e2c}, {v_int = -1081990928, v_long = -1081990928, 
    v_int64 = 34617005827039472, v_double = 2.4016833215892758e-306, 
    v_pointer = 0xbf8220f0}, {v_int = 108014484, v_long = 108014484, 
    v_int64 = 28884720325503892, v_double = 1.0065851872089135e-306, 
    v_pointer = 0x6702b94}, {v_int = 1, v_long = 1, v_int64 = 4294967297, 
    v_double = 2.121995791459338e-314, v_pointer = 0x1}}
	_n_values = <value optimized out>
	value = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0, 
      v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, 
      v_pointer = 0x0}, {v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, 
      v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}}}
	error = <value optimized out>
	column = 1
	__PRETTY_FUNCTION__ = "IA__gtk_tree_model_get_valist"
#1  0x06517417 in IA__gtk_tree_model_get (tree_model=0x88470c0, iter=0x8052df4)
    at gtktreemodel.c:1404
	__PRETTY_FUNCTION__ = "IA__gtk_tree_model_get"
#2  0x0804c955 in xkb_settings_update_from_ui (xkb=0x886ca00)
    at xkb-settings-dialog.c:729
	layouts = <value optimized out>
	variants = <value optimized out>
	kbdmodel = (gchar *) 0x8856000 "\030Q\205\b\001"
	toggle_option = <value optimized out>
	config = (t_xkb_kbd_config *) 0x889e5c8
	is_default = <value optimized out>
	i = <value optimized out>
#3  0x0804ec34 in on_settings_close (dialog=0x8956810, response=-5, 
    xkb=0x886ca00) at xkb-settings-dialog.c:77
No locals.
#4  0x0063f17c in g_cclosure_marshal_VOID () from /lib/libgobject-2.0.so.0
No symbol table info available.
#5  0x00630382 in g_closure_invoke () from /lib/libgobject-2.0.so.0
No symbol table info available.
#6  0x006470c8 in ?? () from /lib/libgobject-2.0.so.0
No symbol table info available.
#7  0x00648415 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
No symbol table info available.
#8  0x006488c6 in g_signal_emit () from /lib/libgobject-2.0.so.0
No symbol table info available.
#9  0x063be4b1 in IA__gtk_dialog_response (dialog=0x8956810, response_id=-5)
    at gtkdialog.c:906
	__PRETTY_FUNCTION__ = "IA__gtk_dialog_response"
#10 0x0063e4cc in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
No symbol table info available.
#11 0x00630382 in g_closure_invoke () from /lib/libgobject-2.0.so.0
No symbol table info available.
#12 0x006470c8 in ?? () from /lib/libgobject-2.0.so.0
No symbol table info available.
#13 0x00648415 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
No symbol table info available.
#14 0x006488c6 in g_signal_emit () from /lib/libgobject-2.0.so.0
No symbol table info available.
#15 0x0638cdca in IA__gtk_button_clicked (button=0x884c8c8) at gtkbutton.c:895
	__PRETTY_FUNCTION__ = "IA__gtk_button_clicked"
#16 0x0638de78 in gtk_real_button_released (button=0x884c8c8)
    at gtkbutton.c:1491
No locals.
#17 0x0063e4cc in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
No symbol table info available.
#18 0x0062e9f9 in ?? () from /lib/libgobject-2.0.so.0
No symbol table info available.
#19 0x00630382 in g_closure_invoke () from /lib/libgobject-2.0.so.0
No symbol table info available.
#20 0x0064684d in ?? () from /lib/libgobject-2.0.so.0
No symbol table info available.
#21 0x00648415 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
No symbol table info available.
#22 0x006488c6 in g_signal_emit () from /lib/libgobject-2.0.so.0
No symbol table info available.
#23 0x0638ce6a in IA__gtk_button_released (button=0x884c8c8) at gtkbutton.c:887
	__PRETTY_FUNCTION__ = "IA__gtk_button_released"
#24 0x0638cea3 in gtk_button_button_release (widget=0x884c8c8, event=0x8c71290)
    at gtkbutton.c:1383
No locals.
#25 0x064415e6 in _gtk_marshal_BOOLEAN__BOXED (closure=0x884f970, 
    return_value=0xbf822cb4, n_param_values=2, param_values=0x8ce8ca0, 
    invocation_hint=0xbf822ca0, marshal_data=0x638ce80) at gtkmarshalers.c:84
	data1 = (void *) 0x884c8c8
	data2 = <value optimized out>
	v_return = <value optimized out>
	__PRETTY_FUNCTION__ = "_gtk_marshal_BOOLEAN__BOXED"
#26 0x0062e9f9 in ?? () from /lib/libgobject-2.0.so.0
No symbol table info available.
#27 0x00630382 in g_closure_invoke () from /lib/libgobject-2.0.so.0
No symbol table info available.
#28 0x00646d47 in ?? () from /lib/libgobject-2.0.so.0
No symbol table info available.
#29 0x006482d0 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
No symbol table info available.
#30 0x006488c6 in g_signal_emit () from /lib/libgobject-2.0.so.0
No symbol table info available.
#31 0x0655698e in gtk_widget_event_internal (widget=0x884c8c8, event=0x8c71290)
    at gtkwidget.c:4745
	signal_num = <value optimized out>
	return_val = 0
#32 0x0643a0fc in IA__gtk_propagate_event (widget=0x884c8c8, event=0x8c71290)
    at gtkmain.c:2391
	tmp = (GtkWidget *) 0x885f610
	handled_event = 147264144
	__PRETTY_FUNCTION__ = "IA__gtk_propagate_event"
#33 0x0643b4a7 in IA__gtk_main_do_event (event=0x8c71290) at gtkmain.c:1596
	event_widget = (GtkWidget *) 0x884c8c8
	grab_widget = (GtkWidget *) 0x884c8c8
	window_group = (GtkWindowGroup *) 0x885f610
	rewritten_event = (GdkEvent *) 0x0
	tmp_list = <value optimized out>
	__PRETTY_FUNCTION__ = "IA__gtk_main_do_event"
#34 0x03f3030a in gdk_event_dispatch (source=0x884bee0, callback=0, 
    user_data=0x0) at gdkevents-x11.c:2365
	display = <value optimized out>
	event = <value optimized out>
#35 0x0057a188 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#36 0x0057d798 in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#37 0x0057dc4f in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#38 0x0643b959 in IA__gtk_main () at gtkmain.c:1200
	tmp_list = (GList *) 0x804bae0
	functions = (GList *) 0x0
	init = (GtkInitFunction *) 0x8050540
	loop = (GMainLoop *) 0x88769c0
#39 0x0804c04f in main (argc=142954776, argv=0x1) at xfce4-xkb-plugin.c:85
	plugin = <value optimized out>


cmdline
-----
/usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin socket_id 28600390 name xkb-plugin id 12410091343 display_name Keyboard Layouts size 25 screen_position 1 

executable
-----
/usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin

kernel
-----
2.6.27.21-170.2.56.fc10.i686

package
-----
xfce4-xkb-plugin-0.5.2-1.fc10
Comment 1 Christoph Wickert 2009-05-08 19:52:14 EDT
Sorry it took so long, but I cannot reproduce your problem, no matter how hard I try.

(In reply to comment #0)
> 1. add keyboard switcher to xfce panel
> 2. Configuration window appears. In this window some parts are not filled (ie.
> keyboard model is blank, change layout option is blank, ...)

Keyboard model is filled automatically with "Generic 105-key (Intl) PC" here and even if I leave layout blank, nothing happens.

> 3. Click on "Close" button to confirm configuration
> 4. keyboard switcher ends with sigsegv

Works fine here.

Can you give me a screenshot of the dialog and a tell me, what locale you are using?
Comment 2 Zdenek Prikryl 2009-05-12 07:46:42 EDT
Now even I cannot reproduce it, so I'm closing it. Maybe I did not have up-to-date system :-/...
Comment 3 Christoph Wickert 2009-05-12 10:39:16 EDT
The xkb-plugin is a little crashy. There is a 0.5.3, but I haven't updated yet because it crashes. Will need to troubleshoot this with upstream, thanks for the reminder.

Note You need to log in before you can comment on or make changes to this bug.