Bug 498210 - webui string typo for syncfail
webui string typo for syncfail
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Mike McCune
Steve Salevan
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-04-29 09:25 EDT by Shannon Hughes
Modified: 2009-09-10 15:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 498208
Environment:
Last Closed: 2009-09-10 15:25:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shannon Hughes 2009-04-29 09:25:16 EDT
Ticket <URL: https://engineering.redhat.com/rt3/Ticket/Display.html?id=39923 >

Request for clarification from writer of java.po:

Reference:
#. ID:"kickstart.cobbler.distro.syncfail"
#: en-US/java.xliff:1274
#, no-c-format

String: (Relevant portion)
The following is a list of errors gathered while Spacewalk attempts to \n
syncronize kickstart distributions from Spacewalk to Cobbler.  These \n
errors must be corrected for the distributions to be available for \n
kickstarting systems kickstart distributions failed to sync from \n
Spacewalk to Cobbler:\n

Reference required for:
'These errors must be corrected for the distributions to be available for kickstarting systems kickstart distributions failed to sync from Spacewalk to Cobbler'
Comment 1 Devan Goodwin 2009-05-04 15:59:09 EDT
Looks like this was meant to be something like:

"These errors must be corrected for the distributions to be available for
kickstarting systems."

The portion after this looks like it might have been a previous version of the error message.
Comment 2 Devan Goodwin 2009-05-04 16:08:18 EDT
Fixed in:

spacewalk.git: 9f2db2d4a32785ffa545a7176bcf4014b57833b2
satellite.git: fd004dea40329b9fb36bc9966f96303360a2cba4

New version of the message reads:

The following is a list of errors gathered while Spacewalk attempts to
syncronize kickstart distributions from Spacewalk to Cobbler.  These
errors must be corrected for the distributions to be available for
kickstarting systems:
Comment 3 Runa Bhattacharjee 2009-05-06 02:13:44 EDT
Thanks a lot Devon. I'll wait for the changes to hit the .po files.
Comment 4 Mike McCune 2009-05-20 13:29:11 EDT
ON_QA
Comment 5 Steve Salevan 2009-06-24 13:22:04 EDT
VERIFIED on 6/19 build.
Comment 6 John Sefler 2009-08-26 15:07:27 EDT
Verified on staged (Satellite-5.3.0-RHEL5-re20090724.0) with updates from Aug 20, 2009

I was not able to force a failure to reveal the error message.  Instead, I found the corrected error string as follows:


mkdir /tmp/rhn
cp /usr/share/rhn/lib/rhn.jar /tmp/rhn
cd /tmp/rhn
jar -xvf rhn.jar 
grep -ir "The following is a list of errors"  com/redhat/rhn/frontend/strings/*
view com/redhat/rhn/frontend/strings/java/StringResource_en_US.xml

Within this file, I found the corrected string:

     <trans-unit id="kickstart.cobbler.distro.syncfail">
        <source>
The following is a list of errors gathered while Spacewalk attempts to
syncronize kickstart distributions from Spacewalk to Cobbler.  These
errors must be corrected for the distributions to be available for
kickstarting systems:

{0}

Please check:

/var/log/rhn/rhn_taskomatic_daemon.log and
/var/log/tomcat5/catalina.out
/var/log/cobbler/cobbler.log

for more detailed errors.  If you don't resolve the errors the kickstart
tree will not be usable for kickstarting.
        </source>
     </trans-unit>


moving to RELEASE_PENDING
Comment 7 Brandon Perkins 2009-09-10 15:25:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.