Bug 498243 - Unable to start GDM
Unable to start GDM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 11:13 EDT by Michael Monreal
Modified: 2009-08-23 23:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-23 23:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (11.32 KB, text/plain)
2009-05-04 19:23 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-04-29 11:13:47 EDT
F11Preview LiveCD does not start GDM, so I'm not able to even install it. What I see is the following being dran on tty0 a lot of times:

nouveau 0000:01:00.0: nouveau_fifo_free: freeing fifo 0

1.) X does *not* fall back to nv or even vesa. 

2.) There's no obvious way (boot option?) for me to tell Fedora to use either of the working drivers. I tried forcing another driver and eventually got GDM to start but I was not able to log in due to some session problems (I guess manually starting GDM after a crash is not *that* easy after all...)

3.) Finally, the release notes don't even mention nouveau and how this may cause problems, which looks to me like the most serious flaw.
Comment 1 Ben Skeggs 2009-05-04 00:34:13 EDT
It would be very useful for you to provide your /var/log/Xorg.0.log so I at least have an idea of what went wrong, so I can fix it :)
Comment 2 Michael Monreal 2009-05-04 19:23:44 EDT
Created attachment 342397 [details]
Xorg.0.log

Here's a recent Xorg.0.log I just did with a F11 Preview Live-CD. It was not easy to get this btw... if I just wait and let it boot, my screen will turn of after a while of flashing. The only way I have found to get into the system is
- ESC'ing plymouth
- waiting for X/GDM to begin loading (screen will flash a bit between console/black/console/...)
- now pressing alt-f2 a few times to get to a login tty
Comment 3 Bug Zapper 2009-06-09 10:47:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Michael Monreal 2009-08-15 08:24:42 EDT
This works with recent Rawhide snapshots now. Feel free to close as OBSOLETE or NEXTRELEASE. I will keep an eye on this and report regressions - I really want to switch to Fedora with F12 :)
Comment 5 Ben Skeggs 2009-08-23 23:00:48 EDT
Thanks for letting me know!

Note You need to log in before you can comment on or make changes to this bug.