Bug 498251 - CLI proxy default version is 0.5 while it should be 5.3
CLI proxy default version is 0.5 while it should be 5.3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Miroslav Suchý
Preethi Thomas
:
: 499458 (view as bug list)
Depends On:
Blocks: 456999 501508
  Show dependency treegraph
 
Reported: 2009-04-29 11:40 EDT by Preethi Thomas
Modified: 2009-09-10 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 501508 (view as bug list)
Environment:
Last Closed: 2009-09-10 10:38:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-04-29 11:40:32 EDT
Description of problem:
CLI proxy default version is 0.5 while it should be 5.3

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090424.1-i386-embedded-oracle.iso
How reproducible:


Steps to Reproduce:
1. install  satellite 530
2. sync tools & proxy channels 
3. register a client
4.  install spacewalk-proxy-installer
5. run configure-proxy.sh without the answer file.
  
Actual results:
root@rlx-3-08 ~]# configure-proxy.sh 
Proxy version to activate [0.5]: 


Expected results:
root@rlx-3-08 ~]# configure-proxy.sh 
Proxy version to activate [5.3]: 


Additional info:
Comment 1 Miroslav Suchý 2009-05-07 04:24:46 EDT
*** Bug 499458 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Suchý 2009-05-19 06:42:58 EDT
I added (commmit c2adc0d9b875737ed0ed58f2254d6bd1b2db002d) new API call which list all available versions of proxy channels for given system.

Next step will be to learn configure-proxy.sh to use this api call.
Comment 3 Miroslav Suchý 2009-05-19 10:31:24 EDT
rhn-activate-proxy now contains option -l, which list all available proxy channel in parent (commit e7052c7fa849924baec2d39893cc06518d1d347d)
configure-proxy.sh now suggest this value as default for proxy activation (commit 8357f7854431c1fd3bd4f4cfbbd03bbba41c10f8)
Comment 4 Miroslav Suchý 2009-05-22 07:39:48 EDT
Satellite-5.3.0-RHEL4-re20090521.1 is out 
moving ON_QA
Comment 5 Preethi Thomas 2009-06-03 13:41:41 EDT
verified 
Satellite-5.3.0-RHEL5-re20090529.0-i386-embedded-oracle.iso
[root@hp-xw6600-01 ~]# configure-proxy.sh
RHN Parent [rlx-3-24.rhndev.redhat.com]: 
Proxy version to activate [5.3]:
Comment 6 Preethi Thomas 2009-08-07 13:25:50 EDT
Release Pending
Comment 7 Brandon Perkins 2009-09-10 10:38:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.