Bug 498257 - nocpulse user oddities after Satellite upgrade
nocpulse user oddities after Satellite upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Zázrivec
Jeff Browning
:
Depends On:
Blocks: 456986 463877
  Show dependency treegraph
 
Reported: 2009-04-29 12:07 EDT by Milan Zázrivec
Modified: 2009-08-27 13:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 13:38:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zázrivec 2009-04-29 12:07:52 EDT
Description of problem:
There are several differences showing up for nocpulse user after a Satellite
upgrade to 5.3.0:

* new installation:

# finger nocpulse
Login: nocpulse                         Name: NOCpulse user
Directory: /var/lib/nocpulse            Shell: /bin/bash
...
# grep noc /etc/passwd
nocpulse:x:102:104:NOCpulse user:/var/lib/nocpulse:/bin/bash


* upgraded Satellite (3.7.0 -> 5.3.0):

# finger nocpulse
Login: nocpulse                         Name: NOCpulse user
Directory: /home/nocpulse               Shell: /bin/bash
...
Login: nocops                           Name: NOCpulse Ops
Directory: /home/nocops                 Shell: /bin/bash
...
# grep noc /etc/passwd
nocpulse:x:502:502:NOCpulse user:/home/nocpulse:/bin/bash
nocops:x:503:503:NOCpulse Ops:/home/nocops:/bin/bash
# diff -q /home/nocpulse/.ssh/nocpulse-identity.pub /var/lib/nocpulse/.ssh/nocpulse-identity.pub 
Files /home/nocpulse/.ssh/nocpulse-identity.pub and /var/lib/nocpulse/.ssh/nocpulse-identity.pub differ

Version-Release number of selected component (if applicable):
nocpulse-common-2.1.8-3

How reproducible:
Always

Steps to Reproduce:
1. Install an older Satellite, upgrade it to 5.3.0
2. See that after upgrade:
* nocpulse user uses /home/nocpulse as a home directory (on a new
  installation it is /var/lib/nocpulse)
* there's a nocops user created (not sure where it comes from)
* new ssh private / public keys are generated during upgrade
* log files in /home/notification & /home/nocpulse are not being moved
  to /var/log/nocpulse & /var/log/notification
  
Actual results:
nocpulse user on an upgraded Satellite is messed up.

Expected results:
nocpulse user on new & upgraded Satellite looks the same.

Additional info:
N/A
Comment 1 Brandon Perkins 2009-04-30 10:40:54 EDT
Please determine if the best approach is to do the modifications within the RPM scripts themselves or within the upgrade procedure.  I think Cliff and I would both prefer to see this done cleanly within RPM if at all possible.
Comment 2 Milan Zázrivec 2009-05-11 07:23:57 EDT
After some investigation -- nocops user is a user we used to create in older
satellites (along with nocpulse user) and does not pose any harm to the system
(as in this user will be in the system after monitoring upgrade). The rest of
the stuff was fixed in:

spacewalk.git master:
a6df75e77146c061435254665d5d9234e9ff5f40
57525b2fd556d8876acdd0082cc76ab26de468c4
7ab36e0c23a7e04d6847888a86154c903d50ae37
8d7ebb4df15bd104e6c1eb578f0f1fdcf997e2ce
4b3903fabd004a5ccbba0baec97ac7af12605d60
b1666278ed053d15b47b4bafb197f3b6f93fd40c
ef26a51e741c919f5cf15e9070b6ada1e91fc774
1bc9eca20654ee4f9f6f12745d36dad78602f3bf

spacewalk.git VADER:
92bd6023a5d0a8f10f054bddce23d9d1c2a49389
b1f342b0c3241fcb912537432238d03b3ef6639d
4e9bae2b62e7b53c966391bc040203ef4113c76f
e23d9d1c2a49389c70f842f898dac82724fe7eda
17f254a71e62128d0c9cf7e5cb17a5655306053b
62768edb9c669d5719d35b0544297843b8427454
b63f71e1dfa0b33d32f5996268acb4ad5859a8f1
ba4a1dd626d6b837f3444aa4777ec810551c1445
Comment 3 Milan Zázrivec 2009-05-14 09:34:22 EDT
spacewalk.git master: a8a673c16af14971da636a00488a1e5c6d91e28f
spacewalk.git VADER: 62bdc668a1f3e07b3534d0fce4b22209d4372035
Comment 4 Milan Zázrivec 2009-05-20 15:22:31 EDT
nocpulse-common-2.1.8-5
NPalert-1.126.7-3
MessageQueue-3.26.2-4
perl-NOCpulse-Scheduler-1.58.11-3
tsdb-1.27.19-2
NOCpulsePlugins-2.208.6-5
SatConfig-installer-3.24.4-4
SputLite-client-0.48.7-2
Comment 5 Jeff Browning 2009-06-16 16:46:22 EDT
Verified
Comment 6 Miroslav Suchý 2009-08-27 06:25:06 EDT
[root@xen15 ~]# finger nocpulse
Login: nocpulse                         Name: NOCpulse user
Directory: /var/lib/nocpulse            Shell: /bin/bash
Never logged in.
Mail forwarded to root
New mail received Thu Aug 20 14:30 2009 (CEST)
     Unread since Thu Aug 20 13:34 2009 (CEST)
No Plan.

Login: nocops                           Name: NOCpulse Ops
Directory: /home/nocops                 Shell: /bin/bash
Never logged in.
No mail.
No Plan.
[root@xen15 ~]# grep nocpulse /etc/passwd
nocpulse:x:102:104:NOCpulse user:/var/lib/nocpulse:/bin/bash

verified in stage on xen15
Comment 7 Brandon Perkins 2009-08-27 13:38:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1235.html

Note You need to log in before you can comment on or make changes to this bug.