Bug 498267 - Installing proxy-installer should install spacewalk-proxy-installer instead
Installing proxy-installer should install spacewalk-proxy-installer instead
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
urgent Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Tomas Lestach
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-04-29 12:57 EDT by Jeff Browning
Modified: 2009-09-10 10:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:38:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Browning 2009-04-29 12:57:40 EDT
Description of problem:
There are currently two different command line proxy installer packages in the tools channels.

proxy-installer-5.2.0-20.el5.noarch

spacewalk-proxy-installer-0.5.25-2.el5sat.noarch

proxy-installer does not function correctly with 5.3, while spacewalk-proxy-installer does. This is going to be extremely confusing for our customers. As such, attempting to install proxy-installer should result in it being seen as outdated, and spacewalk-proxy-installer should be installed instead.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. yum install proxy-installer
  
Actual results:
proxy-install is installed.

Expected results:
spacewalk-proxy-installer should be installed instead.


Additional info:
Comment 1 Miroslav Suchý 2009-04-30 04:22:52 EDT
Commited as 5d4b5d4243275f92c82c817c7fc0c92dce2fd702
Comment 2 Miroslav Suchý 2009-05-11 11:50:11 EDT
Test plan:
make sure when you do 
yum install proxy-installer
that spacewalk-proxy-installer is installed.
Comment 3 Tomas Lestach 2009-06-30 06:32:16 EDT
# yum install proxy-installer
Loaded plugins: rhnplugin
Setting up Install Process
Parsing package install arguments
Package proxy-installer is obsoleted by spacewalk-proxy-installer, trying to install spacewalk-proxy-installer-0.5.25-13.el5sat.noarch instead
Resolving Dependencies
...
Installed: spacewalk-proxy-installer.noarch 0:0.5.25-13.el5sat
Dependency Installed: libxslt.i386 0:1.1.17-2.el5_2.2 rhncfg-management.noarch 0:5.9.5-3.el5sat
Complete!

Same packages will be installed, when running
# yum install spacewalk-proxy-installer
Loaded plugins: rhnplugin
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
...
Installed: spacewalk-proxy-installer.noarch 0:0.5.25-13.el5sat
Dependency Installed: libxslt.i386 0:1.1.17-2.el5_2.2 rhncfg-management.noarch 0:5.9.5-3.el5sat
Complete!

Approved!
Comment 4 Tomas Lestach 2009-06-30 09:53:46 EDT
Verified with Satellite-5.3.0-RHEL5-re20090625.0.
Comment 5 Milan Zázrivec 2009-08-11 11:57:58 EDT
Verified in stage -> RELEASE_PENDING
Comment 6 Brandon Perkins 2009-09-10 10:38:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.