Bug 498268 - gdesklets always errors
gdesklets always errors
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gdesklets (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Luya Tshimbalanga
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 12:59 EDT by Jeff Guerdat
Modified: 2009-05-25 17:22 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.36.1-6.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 17:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 344079 None None None Never

  None (edit)
Description Jeff Guerdat 2009-04-29 12:59:40 EDT
Description of problem:
gdesklets never connects to server when first run (timeout) and generates the error "Could not import tiling module!".  

Version-Release number of selected component (if applicable):
gdesklets-0.36.1-5.fc11.i586.rpm

How reproducible:
Always

Steps to Reproduce:
1.Run gdesklets from terminal
2.Wait for ~1 minute for "Connecting to daemon" to complete.
3.Timeout failure.
  
Actual results:
[jguerdat@toshiba ~]$ gdesklets
Starting gdesklets-daemon...
Connecting to daemon [ ###         ]
==========================================================[04/29/09-12:50:39]===
Could not import tiling module!


Cannot establish connection to daemon: timeout!
The log file might help you solving the problem.

Log has no entries.

Expected results:
gdesklet startup normal with no errors

Additional info:
Comment 1 Luya Tshimbalanga 2009-04-29 16:26:46 EDT
The bug is caused by API incompatibility with python 2.6 which also affects other distributions. Upstream is investigating on it.
Comment 2 Savvas Radevic 2009-04-29 17:22:18 EDT
I'm not very familiar with the rpm packaging system, but in case fedora wants to temporarily fix this (as downstream):
- make python 2.5 devel available during build (python-devel-2.5 ?).
- restrict it to python < 2.6 until a fix is out
- something like the following lines in the .spec file:


%install
rm -rf %{buildroot}
make install DESTDIR=%{buildroot}
for i in `find %{buildroot} -type f`; \
  do sed -i -e '1s,#!.*python.*,#!/usr/bin/python2.5,' $i; \
done

(not tested on fedora/redhat)
Comment 3 Luya Tshimbalanga 2009-04-30 02:04:45 EDT
Unfortunately the fix is useless because Fedora 11 and Rawhide have not python 2.5 available, only 2.6.
Comment 4 Luya Tshimbalanga 2009-05-13 03:09:26 EDT
Please test http://koji.fedoraproject.org/koji/buildinfo?buildID=101963

This version is patched to address python 3.6 issue until upstream releases 0.36.2
Comment 5 Stephanos Manos 2009-05-22 19:12:56 EDT
(In reply to comment #4)
> Please test http://koji.fedoraproject.org/koji/buildinfo?buildID=101963
> 
> This version is patched to address python 3.6 issue until upstream releases
> 0.36.2  

The 0.36.2 from koji works on x86_64
Comment 6 Jeff Guerdat 2009-05-22 20:54:53 EDT
Sorry, missed this.  The update 0.36.1 works fine.  I see no 0.36.2 in koji.
Comment 7 Fedora Update System 2009-05-23 03:22:30 EDT
gdesklets-0.36.1-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gdesklets-0.36.1-6.fc11
Comment 8 Luya Tshimbalanga 2009-05-23 03:25:07 EDT
0.36.2 is not released yet. Make sure to add karmas on above link so update can be pushed to stable.
Comment 9 Fedora Update System 2009-05-25 17:22:41 EDT
gdesklets-0.36.1-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.