This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 498302 - /usr/share/smolt/client/os_detect.py:103: DeprecationWarning:
/usr/share/smolt/client/os_detect.py:103: DeprecationWarning:
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 15:33 EDT by Jóhann B. Guðmundsson
Modified: 2009-08-27 18:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.3-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 16:26:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2009-04-29 15:33:00 EDT
Description of problem:

/usr/share/smolt/client/os_detect.py:103: DeprecationWarning: os.popen2 is deprecated.  Use the subprocess module.
  child_stdin, child_stdout = os.popen2(command)


Version-Release number of selected component (if applicable):

smolt-1.2-4.2.fc11.noarch

How reproducible:

Always

Steps to Reproduce:
1.SmoltSendProfile
2.
3.
  
Actual results:

The above

Expected results:

No deprecation warning.. 

Additional info:

Minor nuance does not stop to eat babies..
Comment 1 Bug Zapper 2009-06-09 10:48:55 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Mike McGrath 2009-06-22 16:26:55 EDT
Fixed upstream, will be released with the version we're shipping in a week or two.
Comment 3 Mike C 2009-08-25 17:21:24 EDT
Has this update been abandoned?  It is two months since comment #2 !
Comment 4 Fedora Update System 2009-08-26 10:55:37 EDT
smolt-1.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/smolt-1.3-1.fc11
Comment 5 Mike C 2009-08-26 16:56:13 EDT
Closing this bug was perhaps premature.
Trying the new build smolt-1.3-1.fc11
[mike@samsung2 ~]$ smoltSendProfile 
Unable to save UUID, continuing...
Your UUID file could not be created: [Errno 13] Permission denied: '/etc/smolt/hw-uuid'

The file referenced does not exist in the /etc/smolt directory.
Comment 6 Mike McGrath 2009-08-26 17:05:36 EDT
... that has nothing to do with the bug you reported.  I'll fix it in a bit though.
Comment 7 Mike McGrath 2009-08-26 17:16:26 EDT
Oh wait, this is from you not running smolt as root.  It doesn't have permission to write there.
Comment 8 Mike C 2009-08-27 03:11:56 EDT
But I have never had to run smolt as root before F11?  Has policy changed?
Comment 9 Mike C 2009-08-27 03:14:18 EDT
In F10 I can run smoltSendProfile as a normal user and there is no hw-uuid created in /etc/smolt/
Comment 10 Mike C 2009-08-27 05:04:01 EDT
Confirmed that the new version does work as root but not as user - which is more secure and probably better than previous versions.
Comment 11 Mike C 2009-08-27 09:59:27 EDT
The comments I added above refer to running on a Samsung NC10 with smolt data
http://www.smolts.org/client/show/pub_bf13b7f1-dd7f-4f20-a181-8ec47e7a6818

However strangely I tried the original smolt running in F11 on a Dell Dimension 2400 which allowed me to run smoltSendProfile as a normal user though with the originally reported bug symptoms. However it did generate the profile correctly and produced it in 
http://www.smolts.org/client/show/pub_eddb6cf9-b933-4c1b-9eb2-23cb0d984056

Then I updated from smolt-1.2-4.2.fc11 to smolt-1.3-1.fc11
Then it gives the same behaviour as in comments #9 and #10

So it seems that the need to run as root is new behaviour - which I do endorse!
Comment 12 Mike McGrath 2009-08-27 10:12:39 EDT
You can still run smoltSendProfile as a non-root user.  The error you are seeing is a non-fatal error.  It just indicates that normal users can't write to /etc/ because they can't :)
Comment 13 Fedora Update System 2009-08-27 18:56:02 EDT
smolt-1.3-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.