Bug 498333 - RFE: upgrade to newer perl-Net-DNS?
RFE: upgrade to newer perl-Net-DNS?
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl-Net-DNS (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: perl-maint-list
qe-baseos-daemons
: FutureFeature, Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 17:21 EDT by Chris Adams
Modified: 2011-04-06 11:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-06 11:13:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2009-04-29 17:21:13 EDT
I'm trying to parse some BIND zone files, and it looks like the most current perl zone file parser is Net-DNS-ZoneFile-Fast (currently version 1.1).  It requires a newer Net-DNS however, at least version 0.65.  Net-DNS-ZoneFile-Fast also requires Net-DNS-SEC, which requires at least version 0.64 of Net-DNS.

Is there any chance RHEL could update to a newer Net-DNS (at least 0.65)?

Once I packaged and tested Net-DNS-ZoneFile-Fast, I was thinking of submitting it to Fedora and EPEL, but since EPEL does not replace packages in RHEL (which is good), this wouldn't work unless RHEL updates Net-DNS.
Comment 1 RHEL Product and Program Management 2009-11-06 13:44:51 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Petr Pisar 2010-11-26 08:58:48 EST
Upgrade to RHEL-6 (that contains 0.65 version), or provide your business case to Red Hat support service to evaluate your request.
Comment 3 Marcela Mašláňová 2011-04-06 11:13:48 EDT
I'm sorry but it's not probable to update it in RHEL-5. RHEL-6 contain 0.65, so I'd like to close it as next release.

Note You need to log in before you can comment on or make changes to this bug.