Bug 498403 - USB UPS not recognised
USB UPS not recognised
Status: CLOSED DUPLICATE of bug 504496
Product: Fedora
Classification: Fedora
Component: DeviceKit-power (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 06:47 EDT by brianchad@westnet.com.au
Modified: 2009-07-02 08:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 08:55:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brianchad@westnet.com.au 2009-04-30 06:47:28 EDT
Description of problem:


USB UPS not recognised

Version-Release number of selected component (if applicable):

DeviceKit-power-008-0.1.20090401git.fc11.x86_64
gnome-power-manager-2.26.1-2.fc11.x86_64




How reproducible:

it just doesnt work


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

using nut-hal it doesnt work .. deleting nut-hal it doesnt work.

output from devkit-power -d ...

Daemon:
  daemon-version:  008
  can-suspend:     yes
  can-hibernate    yes
  on-battery:      no
  on-low-battery:  no

output from lsusb ...

Bus 001 Device 006: ID 04b8:081b Seiko Epson Corp. MFP Composite Device
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 046d:08b2 Logitech, Inc. QuickCam Pro 4000
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 04a9:220e Canon, Inc. CanoScan N1240U/LiDE 30
Bus 002 Device 004: ID 06da:0003 Phoenixtec Power Co., Ltd 
Bus 002 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

output from lshal | grep UPS ...

udi = '/org/freedesktop/Hal/devices/usb_device_6da_3_noserial'
  battery.type = 'ups'  (string)
  info.addons = {'hald-addon-blazer_usb'} (string list)
  info.bus = 'usb_device'  (string)
  info.capabilities = {'battery'} (string list)
  info.category = 'battery'  (string)
  info.linux.driver = 'usb'  (string)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_1d6b_1_0000_00_13_0'  (string)
  info.product = 'USB UPS'  (string)
  info.subsystem = 'usb_device'  (string)
  info.udi = '/org/freedesktop/Hal/devices/usb_device_6da_3_noserial'  (string)
  info.vendor = 'Phoenixtec Power Co., Ltd'  (string)
  linux.device_file = '/dev/bus/usb/002/004'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'usb'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:13.0/usb2/2-3'  (string)
  usb_device.bus_number = 2  (0x2)  (int)
  usb_device.can_wake_up = true  (bool)
  usb_device.configuration_value = 1  (0x1)  (int)
  usb_device.device_class = 0  (0x0)  (int)
  usb_device.device_protocol = 0  (0x0)  (int)
  usb_device.device_revision_bcd = 1024  (0x400)  (int)
  usb_device.device_subclass = 0  (0x0)  (int)
  usb_device.is_self_powered = false  (bool)
  usb_device.linux.device_number = 4  (0x4)  (int)
  usb_device.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:13.0/usb2/2-3'  (string)
  usb_device.max_power = 100  (0x64)  (int)
  usb_device.num_configurations = 1  (0x1)  (int)
  usb_device.num_interfaces = 1  (0x1)  (int)
  usb_device.num_ports = 0  (0x0)  (int)
  usb_device.product = 'USB UPS'  (string)
  usb_device.product_id = 3  (0x3)  (int)
  usb_device.speed = 1.5 (1.5) (double)
  usb_device.vendor = 'Phoenixtec Power Co., Ltd'  (string)
  usb_device.vendor_id = 1754  (0x6da)  (int)
  usb_device.version = 1.1 (1.1) (double)


Using the UPS on serial ports needs NUT Megatec driver
Comment 1 Bug Zapper 2009-06-09 10:52:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Johnathan 2009-06-20 14:54:18 EDT
I am having the same problem. Past versions of Fedora have been able to detect my UPS without a problem. I have a CyberPower 1500 connected to my USB port. I tested it with Ubuntu 9.04 and it detects it fine.
Comment 3 Richard Hughes 2009-07-02 08:55:21 EDT

*** This bug has been marked as a duplicate of bug 504496 ***

Note You need to log in before you can comment on or make changes to this bug.