Bug 498406 - [RHEL5.4]: Xen systems fail to start the cpuspeed service
[RHEL5.4]: Xen systems fail to start the cpuspeed service
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cpuspeed (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Jarod Wilson
BaseOS QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 07:05 EDT by Chris Lalancette
Modified: 2013-04-12 16:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 06:05:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lalancette 2009-04-30 07:05:38 EDT
Description of problem:
Jarod,
     I'm really sorry about this.  The patch to solve bz 488924 has completely broken cpuspeed on Xen-enabled kernels.  The problem is that cpuspeed starts *way* earlier in the boot process than xend does, and without xend, you can't actually run xm commands :(.  So what happens is that at boot with a xen kernel, it says "CPU freq scaling disabled, unable to talk to xen hypervisor", and no frequency scaling is enabled.

At this point, this minor problem has caused more problems than it has fixed, so I would suggest backing it out and closing 488924 WONTFIX.  Unless you have another bright idea of how to fix this.

Chris Lalancette
Comment 1 RHEL Product and Program Management 2009-04-30 07:07:05 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 11 errata-xmlrpc 2009-05-20 06:05:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0424.html

Note You need to log in before you can comment on or make changes to this bug.