Bug 498439 - NetworkManager-vpnc doesn't work
NetworkManager-vpnc doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 10:16 EDT by Dan Winship
Modified: 2009-05-11 09:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 09:27:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Winship 2009-04-30 10:16:01 EDT
NetworkManager-0.7.1-3.git20090414.fc11.i586
NetworkManager-vpnc-0.7.0.99-1.fc11.i586

(note version mismatch. But this is the latest version of each package)

trying to connect with the user password set to "Always Ask" fails immediately with:

    The VPN connection 'Red Hat' failed because there were no valid VPN
    secrets.

and in .xsession-errors:

    ** (nm-applet:2247): WARNING **: _nm_object_get_property: Error getting
    'State' for /org/freedesktop/NetworkManager/ActiveConnection/9: Method
    "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties"
    doesn't exist

Editing the passwords settings in the connection editor gives this in .xsession-errors:

    ** (nm-connection-editor:29392): WARNING **: Unhandled setting secret
    type (write) 'vpn/secrets' : 'GHashTable_gchararray+gchararray_'
Comment 1 Dan Winship 2009-05-11 09:27:32 EDT
hm... this seems to be working now?

NetworkManager-0.7.1-4.git20090414.fc11.i586
NetworkManager-vpnc-0.7.0.99-1.fc11.i586

Note You need to log in before you can comment on or make changes to this bug.