Bug 498476 - widgets.inc produces E_NOTICE level errors
widgets.inc produces E_NOTICE level errors
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All All
low Severity low
: ---
: ---
Assigned To: Fedora Websites Team
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 12:50 EDT by Philip Olson
Modified: 2009-08-05 14:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 19:58:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eliminates E_NOTICE errors from widgets.inc (759 bytes, patch)
2009-04-30 12:50 EDT, Philip Olson
no flags Details | Diff

  None (edit)
Description Philip Olson 2009-04-30 12:50:05 EDT
Created attachment 341957 [details]
eliminates E_NOTICE errors from widgets.inc

The following file creates PHP E_NOTICE level errors:

/cvs/fedora/web/include/widgets.inc

The attached patch solves this (at least the one that people reported in IRC). This patch is safe because side_nav_traverse() also checks for empty(), so a value of 0 has no use here.

Another option is to hide E_NOTICE level errors but I don't feel that's the proper route...
Comment 1 Karsten Wade 2009-05-05 11:53:41 EDT
I fixed this in my local checkout and it looks fine.  However, I'm not a PHP programmer so cannot independently varify the quality of the fix compared to what is there already.

Philip -- it's more a matter of making sure we're not introducing a worse problem.  Can we find someone from #fedora-admin to verify the fix and I'll apply it?
Comment 2 Patrick Barnes 2009-05-05 19:24:23 EDT
I can confirm that this is the correct way to fix this issue.
Comment 3 Karsten Wade 2009-05-05 19:58:01 EDT
OK, thanks Patrick.

The fix is in CVS and tagged LIVE.  It should get grabbed in the next rebuild of the site, which IIRC is done 4 times a day.

Thanks for the catch and the patch!
Comment 4 eric@christensenplace.us 2009-08-05 14:43:32 EDT
Tickets move to docs-request so the fedora-websites component can be removed per request from Ricky.

Note You need to log in before you can comment on or make changes to this bug.