Bug 49861 - rdist doesn't run on linux when executed from and HP-UX system.
rdist doesn't run on linux when executed from and HP-UX system.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rdist (Show other bugs)
6.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-24 13:32 EDT by Need Real Name
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-24 13:32:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-24 13:32:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (WinNT; U)

Description of problem:
rdist on the linux RedHat 6.2 doesn't run when executed from and HP-UX system.  The error the HP-UX system reports is the following:
     rdist: got unexpected input (rdist may not exist on remote host)

After reading the man pages for rdist on the Linux RedHat 6.2 system, it appears that Linux has a different version of rdist.  The solution that 
the man pages reported was to run the oldrdist in /usr/bin.  This happens when the -Server option is used.  Here is the error that the Linux 
system reports when running rdist -Server:
     'hostname':  LOCAL ERROR:  Exec old rdist failed: /usr/bin/oldrdist:  No such file or directory.

Where can I get this oldrdist component, or how can I resolve this issue?

How reproducible:
Always

Steps to Reproduce:
1. Create an rdistfile on the HP-UX system.
2. Run rdist on the HP-UX system.  (Error should show up)
3. To see error on Linux system, type rdist -Server.
	

Actual Results:  See description above.

Additional info:
Comment 1 Phil Knirsch 2001-07-25 08:18:45 EDT
OK, the problem is clear:

In 1994 a comletely new and incompatible version of rdist appeard and has since
then become the standard for rdist use.

RedHat never shiped that obsolete version of rdist with on distribution.

There are basically two options:

1) Use the current and maintained Linux source of the rdist package, compile it
on HP-UX and use that instead of the original HP-UX binary.

2) Find the source code to the old rdist program and try to compile it on the
Linux machine.

Depending on wether you have a compiler for the HP-UX machine and on the number
of HP-UX affected the 1st solution might not be possible.

The problem for the 2nd solution is to find an old enough rdist source. I have
found one dated back to 1991 which might be compatible with the HP-UX version,
but i cannot validate that as we don't have HP-UX machines to test on.

What actually really puzzles me is that HP still ships such an outdated version
of rdist. It hasn't been maintained for a very long time and surely will contain
 bugs that are much more likely to be already fixed in the current maintained
version of rdist.

I'd be interested which version of HP-UX that is... Current is 11.xx (AFAIK),
10.20 has been around for quite some time and 9.xx was current when i still was
at the university.

Read ya, Phil
PS: Should you need the source tarball of the old rdist source just drop me a
quick note, i can send it to you via email (it's only a 35kb tarball ;).
Comment 2 Need Real Name 2001-07-25 08:31:53 EDT
Phil,

Please email me the tar file you found.  We found a few older versions but they wouldn't compile on the Linux system.  They
were bsd files.  Perhaps the version you have will be compatible with HP-UX.

Thanks,

Tay Amer

Note You need to log in before you can comment on or make changes to this bug.