Bug 498678 - Changes to rhnlib for RHEL 4.8 breaks RHN Proxy 5.2 (and perhaps earlier).
Changes to rhnlib for RHEL 4.8 breaks RHN Proxy 5.2 (and perhaps earlier).
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhnlib (Show other bugs)
4.8
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
: Regression
: 497981 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-01 16:36 EDT by Brandon Perkins
Modified: 2009-05-18 16:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:14:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proxy Traceback (2.52 KB, text/plain)
2009-05-01 16:36 EDT, Brandon Perkins
no flags Details

  None (edit)
Description Brandon Perkins 2009-05-01 16:36:52 EDT
Created attachment 342151 [details]
Proxy Traceback

Description of problem:
Changes to rhnlib for RHEL 4.8 breaks RHN Proxy 5.2 (and perhaps earlier).

Version-Release number of selected component (if applicable):
rhnlib-2.1.4-5.el4

How reproducible:
Always.

Steps to Reproduce:
1. Install and fully update a RHEL4 box to RHEL 4.8.
2. Install RHN Proxy 5.2 on said box.
3. Register a client system through the RHN Proxy.
4. Attempt to up2date the client system.
  
Actual results:
# up2date -u
Fetching Obsoletes list for channel: rhel-i386-as-4...
Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...
Fetching Obsoletes list for channel: rhel-i386-as-4-extras...
Fetching rpm headers...
There was a fatal error communicating with the server. The message was:
Internal Server Error

A traceback also is generated from the Proxy, which is attached.

Expected results:
Proper updating of the client system.

Additional info:
Rolling back to the RHEL 4.7 version rhnlib-2.1.2-11.el4 fixes the issue.
I believe this regression was introduced as a result of fixing bug 434781
Comment 1 Brandon Perkins 2009-05-01 16:39:24 EDT
Actually, more likely, the regression was introduced as a result of fixing bug 443366
Comment 10 Petr Sklenar 2009-05-05 04:47:48 EDT
*** Bug 497981 has been marked as a duplicate of this bug. ***
Comment 15 errata-xmlrpc 2009-05-18 16:14:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0974.html

Note You need to log in before you can comment on or make changes to this bug.