Bug 498680 - needs "Requires(post): /bin/chmod"
needs "Requires(post): /bin/chmod"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: docbook-dtds (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-01 16:56 EDT by Thorsten Leemhuis
Modified: 2009-05-12 01:06 EDT (History)
1 user (show)

See Also:
Fixed In Version: docbook-dtds-1.0-47.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 06:10:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2009-05-01 16:56:49 EDT
Description of problem:
Saw this when using livecd-creator:

  Installing: docbook-dtds                 ################### [ 335/1004]/var/tmp/rpm-tmp.YAqApJ: line 95: /bin/chmod: No such file or directory
warning: %post(docbook-dtds-1.0-46.fc11.noarch) scriptlet failed, exit status 127
 
Version-Release number of selected component (if applicable):
docbook-dtds-1.0-46.fc11.noarch

How reproducible:
always

Additional info:
A "Requires(post): /bin/chmod" in the spec file should fix this. Would be nice to get this fixed for F11
Comment 1 Ondrej Vasik 2009-05-11 06:10:14 EDT
Thanks for report, fixed in RAWHIDE. In fact this failure of chmod is harmless as the ent files are readable - so I guess there is no reason for breaking F11 freeze for final policy and fixing this for F11. Closing RAWHIDE, if you have some arguments what is severely broken without that added requires, I'll do updates for F-9/F-10/F-11 as well. Otherwise I'll fix it with next future update for those Fedoras (if there will be such update).
Comment 2 Thorsten Leemhuis 2009-05-11 06:27:12 EDT
(In reply to comment #1)
> Thanks for report, fixed in RAWHIDE. In fact this failure of chmod is harmless
> as the ent files are readable - so I guess there is no reason for breaking F11
> freeze for final policy and fixing this for F11. Closing RAWHIDE, if you have
> some arguments what is severely broken without that added requires, I'll do
> updates for F-9/F-10/F-11 as well. Otherwise I'll fix it with next future
> update for those Fedoras (if there will be such update).  

I for one would say that these error messages might confuse people a lot when they create remixes or spins and hence it's IMHO worth to get this fix into F11. I guess that that should be mostly safe if nothing changed apart from the require. 

Maybe simply asking Jesse/rel-eng for his/their option might be best.
Comment 3 Ondrej Vasik 2009-05-11 15:05:37 EDT
You are right, it's easy change and might be confusing. Submitted to releng as https://fedorahosted.org/rel-eng/ticket/1780.
Comment 4 Ondrej Vasik 2009-05-12 01:06:09 EDT
Ok, tagged for f11-final ...

Note You need to log in before you can comment on or make changes to this bug.