Bug 498690 - F11 Hangs on Reboot or Shutdown
F11 Hangs on Reboot or Shutdown
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-01 20:38 EDT by Brian C. Lane
Modified: 2009-05-18 13:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 13:12:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian C. Lane 2009-05-01 20:38:47 EDT
Description of problem:
After upgrading today F11 won't reboot without doing a CTRL-ALT-BKSP to kill X and then a bunch of CTRL-ALT-DELs to get the init scripts to finish.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Select shutdown from the menu
2. I see it shut down all the GNOME elements, and then hang with only the desktop image visible. Mouse clicks do nothing.
3. CTRL-ALT-BKSP
4. Drop to console but won't finish shutdown
5. Multiple CTRL-ALT-DELs to convince the scripts to finish and shutdown
  
Actual results:


Expected results:
Shutdown with no intervention

Additional info:
Core2 Duo system, 4G RAM with Nvidia chipset motherboard and using the nouveu x11 driver.
Comment 1 Ben Skeggs 2009-05-01 20:49:26 EDT
What makes you think this is an issue with nouveau?
Comment 2 Brian C. Lane 2009-05-01 23:38:00 EDT
Well, I'm not sure exactly which part it is an issue with. But that seemed like a good starting point since I have to CTRL-ALT-BKSP to get it to drop back to the console.
Comment 3 Ben Skeggs 2009-05-04 00:41:37 EDT
The video driver's involvement in switching back to a VT is exactly the same no matter whether you press logout, or ctrl+alt+bksp :)

In any case, just to be sure, can you switch to the nv or vesa drivers and try to reproduce?
Comment 4 Brian C. Lane 2009-05-04 12:13:41 EDT
With the vesa driver a reboot acts the same. A shutdown was successful without intervention. The nv driver doesn't work with my card.

I also noticed the following:

1. After switching to console (CTRL-ALT-F2) the login prompt doesn't respond. That would indicate to me that the shutdown process is at least past that point.
2. The first line that appears when doing a CTRL-ALT-DEL is 'disabling monthly Smolt Update'
Comment 5 Christoph Breitkopf 2009-05-06 06:14:39 EDT
Same thing happens on my notebook:

- hangs during shutdown
- After switching to console (CTRL-ALT-F2) the login prompt doesn't respond.
- need 1 times CTRL-ALT-DEL to continue
- The first line that appears when doing a CTRL-ALT-DEL is 'disabling monthly
Smolt Update'
- after that, it always REBOOTS, even if I selected shutdown

System config:

HP 6715b, ATI Radeon 690, F11 beta 64-bit (updates up to 2009-05-04)
Comment 6 Christoph Breitkopf 2009-05-06 06:17:26 EDT
(In reply to comment #5)
> HP 6715b, ATI Radeon 690, F11 beta 64-bit (updates up to 2009-05-04)  

Forgot to add: using nomodeset kernel option
Comment 7 Matěj Cepl 2009-05-15 19:52:09 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please EVERYBODY ON THIS BUG attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 8 Brian C. Lane 2009-05-16 00:32:33 EDT
I was using the Nouveu driver with no xorg.conf file.

But now it is working fine using the current version of f11 where /etc/redhat-release reports Fedora release 11 (Leonidas) and the rawhide repos have been replaced with the f11 repos.
Comment 9 Matěj Cepl 2009-05-16 03:37:09 EDT
Anybody else can reproduce it with the latest upgrades to Rawhide?
Comment 10 Christoph Breitkopf 2009-05-18 12:58:56 EDT
Same for me - no longer reproducible with latest updates.
Comment 11 Matěj Cepl 2009-05-18 13:12:39 EDT
Thanks for letting us know

Note You need to log in before you can comment on or make changes to this bug.