Bug 498696 - tracker can't find libtracker-common.so.0
tracker can't find libtracker-common.so.0
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: tracker (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 00:21 EDT by Evan Klitzke
Modified: 2009-09-18 23:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 11:34:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of ldconfig -p (70.60 KB, text/plain)
2009-05-03 16:59 EDT, Evan Klitzke
no flags Details

  None (edit)
Description Evan Klitzke 2009-05-02 00:21:38 EDT
[evan@localhost ~]$ tracker-preferences 
tracker-preferences: error while loading shared libraries: libtracker-common.so.0: cannot open shared object file: No such file or directory

The .so actually resides at /usr/lib64/tracker/libtracker-common.so.0 . Strace'ing tracker-preferences show's that it's looking in /usr/lib64, but not in /usr/lib64/tracker; end of strace output looks like this:

open("/lib64/tls/libtracker-common.so.0", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib64/libtracker-common.so.0", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/tls/libtracker-common.so.0", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/libtracker-common.so.0", O_RDONLY) = -1 ENOENT (No such file or directory)
writev(2, [{"tracker-preferences"..., 19}, {": "..., 2}, {"error while loading shared librar"..., 36}, {": "..., 2}, {"libtracker-common.so.0"..., 22}, {": "..., 2}, {"cannot open shared object file"..., 30}, {": "..., 2}, {"No such file or directory"..., 25}, {"\n"..., 1}], 10tracker-preferences: error while loading shared libraries: libtracker-common.so.0: cannot open shared object file: No such file or directory



my tracker is:
Name       : tracker
Arch       : x86_64
Version    : 0.6.93
Release    : 1.fc11


my tracker-search-tool (which provides tracker-preferences) is:
Name       : tracker-search-tool
Arch       : x86_64
Version    : 0.6.93
Release    : 1.fc11
Comment 1 Deji Akingunola 2009-05-02 21:03:11 EDT
I can't reproduce this. Can you show me the output of running 'ldconfig -p' on your system?
I think you might have tinkered with you LD_LIBRARY environment.
Comment 2 Evan Klitzke 2009-05-03 16:59:35 EDT
Created attachment 342252 [details]
output of ldconfig -p

Output of ldconfig -p
Comment 3 Evan Klitzke 2009-05-03 17:01:17 EDT
I don't have any LD* variables set in my environment, but I think it's likely that I've run ldconfig manually on this machine in the past. FWIW I manually ran "ldconfig /usr/lib64/tracker" and now the tracker commands work for me. The file I attached is from before I ran ldconfig on the tracker directory.
Comment 4 Deji Akingunola 2009-05-03 17:17:02 EDT
(In reply to comment #2)
> Created an attachment (id=342252) [details]
> output of ldconfig -p
> 
> Output of ldconfig -p  
I actually wanted to asked you to run ldconfig -p | grep tracker; thanks for however pasting the whole output, which confirms /usr/lib64/tracker is not in your ldconfig cache.
I think something (likely caused by yourself) has messed up your system's ldconfig cache. Can you please confirm the presence of /etc/ld.so.conf.d/ tracker-x86_64.conf on your affected system, and that it rightly contains /usr/lib64/tracker?
Comment 5 Michael Wise 2009-05-14 08:28:05 EDT
I just installed tracker-0.6.94-1.fc11.x86_64 and I'm having the same issue.  /etc/ld.so.conf.d/tracker-x86_64.conf exists on my machine.  Running ldconfig -p|grep tracker lists nothing.  This is a fresh install of Fedora 11 preview that has been updated daily.
Comment 6 Deji Akingunola 2009-05-14 09:01:35 EDT
(In reply to comment #5)
> I just installed tracker-0.6.94-1.fc11.x86_64 and I'm having the same issue. 
> /etc/ld.so.conf.d/tracker-x86_64.conf exists on my machine.  Running ldconfig
> -p|grep tracker lists nothing.
This is wierd, I can't reproduce it. Can you please  run '/sbin/ldconfig' as root, and see if 'ldconfig -p | grep tracker' then produce something.
Comment 7 Michael Wise 2009-05-14 10:11:06 EDT
I ran /sbin/ldconfig and that seems to have fixed the issue. This is what I get now:

libtrackerclient.so.0 (libc6,x86-64) => /usr/lib64/libtrackerclient.so.0
	libtracker-module.so.0 (libc6,x86-64) => /usr/lib64/tracker/libtracker-module.so.0
	libtracker-module.so (libc6,x86-64) => /usr/lib64/tracker/libtracker-module.so
	libtracker-gtk.so.0 (libc6,x86-64) => /usr/lib64/libtracker-gtk.so.0
	libtracker-db.so.0 (libc6,x86-64) => /usr/lib64/tracker/libtracker-db.so.0
	libtracker-db.so (libc6,x86-64) => /usr/lib64/tracker/libtracker-db.so
	libtracker-data.so.0 (libc6,x86-64) => /usr/lib64/tracker/libtracker-data.so.0
	libtracker-data.so (libc6,x86-64) => /usr/lib64/tracker/libtracker-data.so
	libtracker-common.so.0 (libc6,x86-64) => /usr/lib64/tracker/libtracker-common.so.0
	libtracker-common.so (libc6,x86-64) => /usr/lib64/tracker/libtracker-common.so
	libstemmer.so.0 (libc6,x86-64) => /usr/lib64/tracker/libstemmer.so.0
	libstemmer.so (libc6,x86-64) => /usr/lib64/tracker/libstemmer.so

I no longer get the error.
Comment 8 Deji Akingunola 2009-05-14 11:34:18 EDT
Closing as WORKSFORME. Feel free to reopen if you think this is caused by some specific packaging bug.
Comment 9 Andre Costa 2009-08-11 17:09:41 EDT
Hi,

I was having the same problem described by others (just installed tracker on F11, and it complained about libtracker-common.so.0 not being found). Had to manually run ldconfig as well to fix this. It does look like something that should have been done during installation was missing.
Comment 10 jonathan baron 2009-09-01 20:44:06 EDT
I had exactly the same problem as #9, on Fedora 11 x86_64.
I think this should be re-opened, but I don't seem to have permission to do it.
Comment 11 Cosmin Deaconu 2009-09-18 23:50:50 EDT
I can confirm that ldconfig must be run manually before tracker will work (Fedora 11, i586).

Note You need to log in before you can comment on or make changes to this bug.