Bug 498735 - Please allow adding keywords when initially creating a bug
Please allow adding keywords when initially creating a bug
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.2
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 12:47 EDT by Bruno Wolff III
Modified: 2013-06-23 22:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 11:58:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Segment of the bug entry page that should contain the keywords field (26.31 KB, image/png)
2009-05-03 08:22 EDT, Emmanuel Seyman
no flags Details
Saved html from the page (537.80 KB, text/html)
2009-05-03 11:14 EDT, Bruno Wolff III
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 491316 None None None Never

  None (edit)
Description Bruno Wolff III 2009-05-02 12:47:17 EDT
Description of problem:
It would be easier to remember to add the futurefeature keyword if there was a place to enter it when initially submitting a bug.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Emmanuel Seyman 2009-05-02 18:50:37 EDT
(In reply to comment #0)
>
> It would be easier to remember to add the futurefeature keyword if there was a
> place to enter it when initially submitting a bug.

Isn't this possible, now?

When I enter a bug, I do see a Keywords field present (I haven't tried to submit a bug just to see if futurefeature can be used but I don't see what could you from doing so).
Comment 2 Bruno Wolff III 2009-05-03 01:37:34 EDT
I don't see it on the initial screen. It's there after I submit the bug. I tested with javascript on (normally I have it off). This is with redhat's bugzilla (https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora) and might not be the normal case for random bugzillas. (In which case it's really an infrastructure problem.)
Maybe I am missing an entry box somewhere, but I had done a search in firefox for the string key on the page and that didn't find anything.
Comment 3 Emmanuel Seyman 2009-05-03 08:22:07 EDT
Created attachment 342224 [details]
Segment of the bug entry page that should contain the keywords field

(In reply to comment #2)
> I don't see it on the initial screen. It's there after I submit the bug. I
> tested with javascript on (normally I have it off). This is with redhat's
> bugzilla (https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora)

That's what I thought from the 'futurefeature' keyword.

> and might not be the normal case for random bugzillas.

There are three possibilities here:

a) the Bugzilla instance has been modified to remove the keywords fields during bug entry.
b) the reporter does not have the editbugs right for the product he is entering a bug against
c) no keywords have been defined

> Maybe I am missing an entry box somewhere, but I had done a search in firefox
> for the string key on the page and that didn't find anything.  

Screenshot attached.
Comment 4 Bruno Wolff III 2009-05-03 11:14:56 EDT
Created attachment 342237 [details]
Saved html from the page

I have attached the html page I get. I searched it for keyw and only found a hit for a perl application. I didn't attach some of the dependent css and js files as I don't think they are likly to be an issue.
I was detected as being logged in.
Comment 5 Emmanuel Seyman 2009-05-03 16:24:59 EDT
(In reply to comment #4)
> 
> I have attached the html page I get.

You don't have editbugs capabilities.

At this point, I feel more comfortable filing the bug against the Bugzilla product. I suspect RH's Bugzilla team will be better able to explain why you don't have this right.
Comment 6 Bruno Wolff III 2009-05-03 18:02:06 EDT
I don't know enough about bugzilla to say if this is a configuration issue or a bugzilla itself issue. So assigning it the RH bugzilla team seems reasonable.

But there is still something odd about the design (at least as configured). If I can edit my bugs, I should be able to "edit" a bug I am about to create.
Comment 7 David Lawrence 2009-05-04 11:58:35 EDT
It is by design at least by the upstream developers. The Keywords field (along with blocks/dependson) is hidden to those who are not in the editbugs group for a particular product. In this case you need to be in the fedora_contrib permission group in order to edit the keywords field on bug creation. That would explain why some see it and some do not. Again this is not something Red Hat added in and is there from the upstream code. Please file the bug there at http://bugzilla.mozilla.org this is not satisfactory.

Dave
Comment 8 Emmanuel Seyman 2009-05-04 12:15:11 EDT
(In reply to comment #7)
>
> Please file the bug there at http://bugzilla.mozilla.org if
> this is not satisfactory.

Please don't. The default in upstream bugzilla is to have everyone given editbugs privileges (the "User RegExp" field is set to ".*"). Bruno does not have this right because Red Hat changed the upstream defaults to something else.
Comment 9 Bruno Wolff III 2009-05-04 13:01:59 EDT
I have filed the enhancement request upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=491316
Comment 10 Bruno Wolff III 2009-05-04 13:08:21 EDT
Even if redhat has changed the default config, there still seems to be an issue in that when creating bugs you should be treated as the owner (unless there is some config where you can report a bug and not start out as the owner) and should have the same privileges as the owner of the bug.
So I think this is really an upstream issue. They might still refuse to change things. However it seems that Redhat isn't interested in making a customization to allow this (given there is an annoying, but simple work around, and probably not a lot of demand).
Comment 11 Emmanuel Seyman 2009-05-04 15:25:15 EDT
(In reply to comment #9)
>
> I have filed the enhancement request upstream:

RESOLVED WORKSFORME.

(In reply to comment #10)
>
> Even if redhat has changed the default config, there still seems to be an issue
> in that when creating bugs you should be treated as the owner (unless there is
> some config where you can report a bug and not start out as the owner) and
> should have the same privileges as the owner of the bug.

The reporter never stop being the owner (actually, one of the owners) of a bug. These fields (and others) are conditional simply so that bug entry can be simplified for beginner reporters.

> So I think this is really an upstream issue. They might still refuse to change
> things. However it seems that Redhat isn't interested in making a customization
> to allow this (given there is an annoying, but simple work around, and probably
> not a lot of demand).

There is no customization required. All it takes is for someone from the admin group to access your account and give you the editbugs right manually instead of waiting for you to inherit it via group membership.
Comment 12 Bruno Wolff III 2009-05-04 16:27:24 EDT
However giving me editbugs has security implications. It may well be that it is reasonable for someone to grant me that access.
It seems wrong that this feature is being used to simplify forms as well as control elevated access. Those should really be controlled by two separate knobs. The one that controls simplified forms should be settable by the user on their own.

I did reopen the ticket upstream, but my guess is they will close it WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.