Bug 498765 - update of selinux-policy-mls throws odd error msg 'semodule: failed with !'
update of selinux-policy-mls throws odd error msg 'semodule: failed with !'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-mls (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 02:24 EDT by Valdis Kletnieks
Modified: 2009-08-21 17:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 17:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2009-05-03 02:24:07 EDT
Description of problem:
the postinstall scriptlet of the RPM issues an odd error message:

semodule: failed with !

This is apparently due to a stray "" in the scriptlet.  'rpm -q scripts' shows this line (somewhat truncated):

( cd /usr/share/selinux/mls; 
semodule -b base.pp.bz2 -i ada.pp.bz2 cpufreqselector.pp.bz2 ...(lots of files skipped)...
zosremote.pp.bz2 pingd.pp.bz2 milter.pp.bz2 wm.pp.bz2  "" -s mls; 

Manually issuing that command generates the same message - removing the "" at the end fixes is.  Was the "" supposed to be wrapping a $something variable that got lost somewhere?


Version-Release number of selected component (if applicable):
selinux-policy-mls-3.6.12-23.fc11.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bug Zapper 2009-06-09 11:02:31 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Daniel Walsh 2009-08-21 17:04:49 EDT
I believe this is fixed in the current release.

Note You need to log in before you can comment on or make changes to this bug.