Bug 498797 - stroubleshoot takes 100% CPU from time to time and segfaults, too
stroubleshoot takes 100% CPU from time to time and segfaults, too
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 08:15 EDT by Lennart Poettering
Modified: 2009-05-04 12:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 12:25:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2009-05-03 08:15:54 EDT
Something is not right with setroubleshoot. Currently I have three instances running due to some reasons and they seem to spin in a loop taking up 100% CPU time. Due to some reason gdb froze with 100% CPU too when I tried to attach to the setroubleshootd processes to get a back trace (not that it would help much, given that it is python, but i have no clue how to debug python)

Also, dmesg tells me that the daemon segfaulted from time to time:

setroubleshootd[31009] general protection ip:3d73099884 sp:7fffc0e93f10 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[31012] general protection ip:3d73099884 sp:7fffd13a8420 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[31014] general protection ip:3d73099884 sp:7fffd31a4220 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[31883] general protection ip:3d73099884 sp:7fff0229a320 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[31886] general protection ip:3d73099884 sp:7fff3656d5f0 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[31888] general protection ip:3d73099884 sp:7fffd1697710 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[13474] general protection ip:3d73099884 sp:7fff59605680 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[13513] general protection ip:3d73099884 sp:7fff541cd250 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[13515] general protection ip:3d73099884 sp:7fff3ba65ae0 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[13690] general protection ip:3d73099884 sp:7fffd008d110 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[13693] general protection ip:3d73099884 sp:7fff5d2fe380 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[13695] general protection ip:3d73099884 sp:7fff8d7b8830 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[2824] general protection ip:3d73099884 sp:7fffc4307380 error:0 in libpython2.6.so.1.0[3d73000000+169000]
setroubleshootd[2829] general protection ip:3d73099884 sp:7fff61f56fd0 error:0 in libpython2.6.so.1.0[3d73000000+169000]

/var/log/setroubleshoot/setroubleshootd.log is empty.

I am in permissive mode.
Comment 1 Lennart Poettering 2009-05-03 08:16:26 EDT
Oh, that's setroubleshootd, the daemon.
Comment 2 Daniel Walsh 2009-05-04 12:25:36 EDT
Please update your machine to the latest packages.  This is caused by a bug in the python bindings.

yum -y upgrade

I think it is pygtk

Note You need to log in before you can comment on or make changes to this bug.