Bug 498813 - new terminal start shell in "/"
new terminal start shell in "/"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 11:28 EDT by Hubert Figuiere
Modified: 2009-12-07 02:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-07 01:13:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hubert Figuiere 2009-05-03 11:28:24 EDT
Start a new open-terminal

The shell cwd is '/' instead of '$HOME'. Did that right after install with the default bash. Still does that when I set my user to have zsh.

Version is:
gnome-terminal-2.26.1-1.fc11.i586
Comment 1 Matthias Clasen 2009-05-03 12:06:09 EDT
Try updating to 2.26.1-2.fc11. It has the proposed fix for this problem from http://bugzilla.gnome.org/show_bug.cgi?id=565328
Comment 2 Matthias Clasen 2009-05-03 12:08:00 EDT
If that fixes things for you, I'll ask to have it tagged.
Comment 3 Matthias Clasen 2009-05-03 12:09:21 EDT
You can find the build here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=99850
Comment 4 Hubert Figuiere 2009-05-03 22:33:44 EDT
still does it with gnome-terminal-2.26.1-2.fc12.i586 installed from the above link.
Comment 5 Bug Zapper 2009-06-09 11:04:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Rajeesh 2009-06-20 08:40:24 EDT
Had the same problem with 2.26.1-2.fc11. In my case, the procedure to reproduce is:
1. Start gnome-terminal and "su -" on that to be root.
2. Press Shit+Ctrl+Tab to open a new tab.
3. CWD of newly opened tab is "/" instead of $HOME.

NOTE: I had to "su -" on the first terminal to reproduce the behaviour.

Tried installing 2.26.1-2.fc12.i586 as mentioned, got a lot of warnings:
"WARNING: node <gettext_domain> not understood below <schema>"

It doesn't fix the problem either.
Comment 7 Hubert Figuiere 2009-11-06 02:15:24 EST
Still in Fedora 12 beta.
Comment 8 Bug Zapper 2009-11-16 04:57:55 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Matthias Clasen 2009-12-06 21:36:15 EST
cannot reproduce; su - doesn't make a difference here.
Comment 10 Rajeesh 2009-12-07 01:13:45 EST
Gah, should have closed it long time ago. One of the Fedora 11 updates (2.24.x) resolved it.
With gnome-terminal-2.28.1-1.fc12.i686 it is no longer present. Closing the bug.
Comment 11 Rajeesh 2009-12-07 01:18:14 EST
s/2.24.x/2.26.x/

Monday blues! :(
Comment 12 Hubert Figuiere 2009-12-07 02:41:54 EST
comment #7 tells I still have the problem with F12, so closing it is just a bit premature. I use zsh as a shell. Maybe you should enlighten us on what the fix was so I can check it. I have never haad any problem with any other distro, including with said upstream version of GNOME.

Note You need to log in before you can comment on or make changes to this bug.