Bug 498833 - update to newer upstream version 1.8 or 1.9
update to newer upstream version 1.8 or 1.9
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: glom (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 14:49 EDT by Bernard Zijlstra
Modified: 2009-10-28 09:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 09:05:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernard Zijlstra 2009-05-03 14:49:45 EDT
Description of problem:
Same problem as described in:
https://bugs.launchpad.net/ubuntu/+source/glom/+bug/300054

Version-Release number of selected component (if applicable):
glom 1.6.17-1.fc10

Additional info:
Installation from upstream source won't work because configure script stops with message:

checking for GLOM... configure: error: Package requirements (bakery-2.6 >= 2.6.0 gtkmm-2.4 >= 2.10 gthread-2.0 libxslt >= 1.1.10 pygda-3.0 pygtk-2.0 >= 2.6.0 libgdamm-3.0 >= 2.9.82 libgda-3.0 >= 3.0.1 libgda-postgres-3.0 goocanvasmm-1.0 >= 0.9.0 gtksourceviewmm-2.0 iso-codes libepc-1.0 >= 0.3.1 avahi-ui) were not met:

No package 'bakery-2.6' found
No package 'gtkmm-2.4' found
No package 'gthread-2.0' found
No package 'libxslt' found
No package 'pygda-3.0' found
No package 'pygtk-2.0' found
No package 'libgdamm-3.0' found
No package 'libgda-3.0' found
No package 'libgda-postgres-3.0' found
No package 'goocanvasmm-1.0' found
No package 'gtksourceviewmm-2.0' found
No package 'iso-codes' found
No package 'libepc-1.0' found
No package 'avahi-ui' found

bakery version 2.4.4 seems to be the show stopper. An attempt to install bakery version 2.6.3 form upstream source stop to because of dependancy on newer versions.

checking for BAKERY... configure: error: Package requirements (gtkmm-2.4 >= 2.10.0 gconfmm-2.6 >= 2.6.0 libglademm-2.4 >= 2.4.0 libxml++-2.6 >= 2.23.3 giomm-2.4 >= 2.16.0) were not met:

No package 'gtkmm-2.4' found
No package 'gconfmm-2.6' found
No package 'libglademm-2.4' found
No package 'libxml++-2.6' found
No package 'giomm-2.4' found

OS:
Fedora release 10 (Cambridge) X86
kernel 2.6.27.21-170.2.56.fc10.x86_64
all updates installed.
Comment 1 Denis Leroy 2009-05-03 17:08:09 EDT
Right, glom has an particularly difficult dependency chain, and glom is stuck at 1.6 in F-10 for that reason. One of the issues is the goocanvas and goocanvasmm library dependency. We'd have to either work with the goocanvas owner to upgrade that in F-10, or backport the glom goocanvas code to the older API (no idea how feasible that would be).
Comment 2 Denis Leroy 2009-10-28 09:05:33 EDT
Won't be possible for F-10 sorry.

Note You need to log in before you can comment on or make changes to this bug.