Bug 498842 - kipi_plugin/digikam/f-spot upload to gallery2 broken after removing gallery2-remote from fedora?
kipi_plugin/digikam/f-spot upload to gallery2 broken after removing gallery2-...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gallery2 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 17:26 EDT by Torsten Rohlfing
Modified: 2009-05-05 08:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 08:47:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Torsten Rohlfing 2009-05-03 17:26:24 EDT
Description of problem:

Upload of pictures to a FC10 (updated to rawhide) gallery2 server via kipi_plugins (e.g., from digikam or f-spot) are failing. f-spot is detects server as Gallery2, but then shows dialog with "uncaught exception". DigiKam shows similar behavior.

Version-Release number of selected component (if applicable):

gallery2-2.3-7.fc11.noarch
digikam-0.10.0-1.fc10.x86_64
f-spot-0.5.0.3-2.fc10.x86_64


How reproducible:

- Setup Fedora gallery2 server
- Start f-spot
- Select picture, then "Export->Web gallery", set gallery parameters (URL, login, password), try uploading
  

Actual results:

No picture uploaded; instead, error dialog with uncaught exception. In fact, the exception seems to occur before attempting upload, more spcifically, before probing the server for available albums.


Expected results:

Get a list of albums to upload to, the upload picture.


Additional info:

The problem disappears after installing gallary2-remote from the G2 servers, i.e., NOT from fedora repo, from where gallery2-remote was recently deleted due to license and policy issues.

I guess what this bug is trying to get on the record is that the assessment that only few users use the affected jar packages, there is a side effect that disables the kipi_plugin uploads as well.
Comment 1 Gwyn Ciesla 2009-05-04 09:42:57 EDT
Hmm.  The uploadapplet module was removed as well.  Do you know which module provides this functionality?

As an aside, I share your frustration at the removal of functionality, but due to licensing issues, it was either carve out the offending bits or drop gallery2 from Fedora all together.  I've been told that upstream will be better vis a vis licensing for Gallery3, coming in a few months.
Comment 2 Torsten Rohlfing 2009-05-05 02:28:28 EDT
I's say it's "remote" -- uninstalling upploadapplet from my server had no effect; disabling remote made f-spot crash immediately.

No worries about missing functionality -- having easier access to information WHY the functionality was removed might have been nice though. That said, thanks for your work on this package Jon. Much appreciated.
Comment 3 Gwyn Ciesla 2009-05-05 08:47:32 EDT
I thought it had been spelled out in the BZ, but in the future I might put something in the README.

Note You need to log in before you can comment on or make changes to this bug.