Bug 498843 - Upgrade with VNC asks for password after reboot
Upgrade with VNC asks for password after reboot
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 500010 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 17:41 EDT by Martin Ebourne
Modified: 2014-01-21 18:09 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.1.0-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-28 04:13:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Ebourne 2009-05-03 17:41:50 EDT
Description of problem:
Used preupgrade with vnc option to upgrade headless server. Unfortunately the upgrade failed and VNC didn't appear, it seems because the password given was not long enough, so the upgrade had asked for a new one.

Version-Release number of selected component (if applicable):
preupgrade-1.0.1-1.fc10.noarch

How reproducible:
Every time

Steps to Reproduce:
1. preupgrade-cli --dhcp --vnc=keith Rawhide
2. When ready reboot
  
Actual results:
VNC does not appear and upgrade does not occur.
Apparently this is because the password is less than 6 characters so the upgrade is stuck in tty mode asking for a new password.

Expected results:
VNC should appear and upgrade should occur.

Additional info:
The server was headless, and I had to unplug it and lug it around to get a screen, so this is quite unfortunate. Doesn't matter how bad the password is, once we've got to the reboot stage it's too late to do anything about it, so we need to accept it as is.
Comment 1 Will Woods 2009-05-04 11:31:41 EDT
anaconda (and/or the VNC server) demands VNC passwords of at least 6 characters. preupgrade should, obviously, do the same.

I'll fix the preupgrade option parser to make sure we aren't rebooting with bad passwords set up.
Comment 2 Will Woods 2009-05-10 15:17:47 EDT
*** Bug 500010 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2009-05-13 18:47:10 EDT
preupgrade-1.1.0-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/preupgrade-1.1.0-1.fc9
Comment 4 Fedora Update System 2009-05-13 18:48:04 EDT
preupgrade-1.1.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/preupgrade-1.1.0-1.fc11
Comment 5 Fedora Update System 2009-05-15 19:34:09 EDT
preupgrade-1.1.0-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4211
Comment 6 Fedora Update System 2009-05-28 03:58:25 EDT
preupgrade-1.1.0-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-05-28 04:11:09 EDT
preupgrade-1.1.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-05-28 04:13:06 EDT
preupgrade-1.1.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.