Bug 498847 - Gio::File::make_directory_with_parents() - missing implementation
Gio::File::make_directory_with_parents() - missing implementation
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: glibmm24 (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 19:17 EDT by Debarshi Ray
Modified: 2009-06-02 10:26 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.18.2-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 10:26:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Original fix committed by upstream. (1.94 KB, patch)
2009-05-03 19:17 EDT, Debarshi Ray
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 566003 None None None Never

  None (edit)
Description Debarshi Ray 2009-05-03 19:17:24 EDT
Created attachment 342259 [details]
Original fix committed by upstream.

Description of problem:
Gio::File::make_directory_with_parents() is not implemented (in the `file.ccg'
file), causing linker errors.

Version-Release number of selected component (if applicable):
glibmm24-2.18.1-1.fc10

How reproducible:
[rishi@ginger ~]$ objdump -T /usr/lib64/libgiomm-2.4.so | c++filt | grep Gio::File::make_directory_with_parents
0000003d59a3a820 g    DF .text	0000000000000052  Base        Gio::File::make_directory_with_parents(Glib::RefPtr<Gio::Cancellable> const&)
[rishi@ginger ~]$ 
  
Actual results:
Gio::File::make_directory_with_parents() is absent.

Expected results:
Gio::File::make_directory_with_parents() should be present.

Additional info:
Was fixed in glibmm24-2.19.2.
Comment 1 Denis Leroy 2009-05-04 04:11:05 EDT
We can't have F-10 jump to the unstable branch, so this will have to be patched. I'll file a bug upstream and ask for a new 2.18 branch release.
Comment 2 Debarshi Ray 2009-05-04 05:00:26 EDT
(In reply to comment #1)
> We can't have F-10 jump to the unstable branch, so this will have to be
> patched.

I know. That is why I attached the necessary patch to the bug-report. We can possibly maintain it as a downstream patch.

> I'll file a bug upstream and ask for a new 2.18 branch release. 

There was an upstream bug (see above). Maybe you can add to it.
Comment 3 Debarshi Ray 2009-05-04 05:01:21 EDT
For what it is worth, glibmm-2.18.2 is now available but it does not address this problem.
Comment 4 Denis Leroy 2009-05-04 05:09:06 EDT
Hi Debarshi,

Would you mind testing:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1334895

I don't have access to my external disk with my VMs this week.
Comment 5 Debarshi Ray 2009-05-04 13:32:17 EDT
(In reply to comment #4)
> Would you mind testing:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1334895

Works for me.

[rishi@ginger ~]$ objdump -T /usr/lib64/libgiomm-2.4.so | c++filt | grep Gio::File::make_directory_with_parents
000000000003a860 g    DF .text	0000000000000052  Base        Gio::File::make_directory_with_parents(Glib::RefPtr<Gio::Cancellable> const&)
000000000003a8c0 g    DF .text	000000000000003e  Base        Gio::File::make_directory_with_parents()
[rishi@ginger ~]$
Comment 6 Fedora Update System 2009-05-04 17:46:42 EDT
glibmm24-2.18.2-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/glibmm24-2.18.2-1.fc10
Comment 7 Fedora Update System 2009-05-06 19:26:15 EDT
glibmm24-2.18.2-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glibmm24'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4249
Comment 8 Fedora Update System 2009-06-02 10:25:59 EDT
glibmm24-2.18.2-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.