Bug 498891 - man page of btrace contains errors
man page of btrace contains errors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: blktrace (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Eric Sandeen
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 05:44 EDT by Milos Malik
Modified: 2010-05-27 10:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2009-05-04 05:44:05 EDT
Description of problem:
The NAME section of the man page says "btrace - verifies an output file produced by blkparse" which is not true, because btrace is a convenient script, which runs blktrace (as producer) and blkparse (as consumer), and does not verify the output of blkparse.

The SYNOPSIS section contains a redundant word "Usage:".

The EXAMPLE section talks about running blktrace, but it should talk about running btrace.

Version-Release number of selected component (if applicable):
blktrace-1.0.0-3.el5

How reproducible:
always

Steps to Reproduce:
1. see the NAME section of the man page
2. see the SYNOPSIS section of the man page
3. see the EXAMPLE section of the man page
  
Actual results:


Expected results:


Additional info:
Comment 1 Eric Sandeen 2009-05-04 16:21:27 EDT
I've sent a patch fixing these and others upstream:

http://marc.info/?l=linux-btrace&m=124146824114158&w=2
Comment 3 Eric Sandeen 2009-05-13 18:54:07 EDT
Committed & built in blktrace-1.0.0-6.el5
Comment 9 errata-xmlrpc 2009-09-02 05:41:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1284.html

Note You need to log in before you can comment on or make changes to this bug.