Bug 498898 - version is not a necessary part of cmd line when running blktrace, btt, blkparse
version is not a necessary part of cmd line when running blktrace, btt, blkparse
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: blktrace (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Edward Shishkin
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 06:21 EDT by Milos Malik
Modified: 2016-06-06 09:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:21:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2009-05-04 06:21:28 EDT
Description of problem:
When somebody runs blktrace without parameters, it shows the usage message. The usage message suggests that string "1.0.0" is a required parameter, which is not true. IMHO it's not necessary to show the version in the usage message.

Similar problem can be seen when running btt and blkparse without parameters.

Version-Release number of selected component (if applicable):
blktrace-1.0.0-3.el5

How reproducible:
always

Steps to Reproduce:
# blktrace 2>&1 | head -n 2
Usage: blktrace 1.0.0 -d <dev> [ -r debugfs path ] [ -o <output> ] [-k ] [ -w time ] [ -a action ] [ -A action mask ] [ -I  <devs file> ] [ -v ]
# blktrace 1.0.0 -d /dev/sda1
1.0.0: No such file or directory


Actual results:


Expected results:


Additional info:
Comment 3 Eric Sandeen 2009-07-02 12:42:56 EDT
Some of the less critical bugs for blktrace didn't make it for RHEL5.4, but we can get to them in RHEL5.5.

Thanks,
-Eric
Comment 4 RHEL Product and Program Management 2009-11-06 14:07:10 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 Edward Shishkin 2009-12-16 11:15:46 EST
the patch was sent to the upstream
Comment 6 Edward Shishkin 2010-05-17 08:31:16 EDT
This is a pointer to the upstream post:

http://marc.info/?l=linux-btrace&m=126089936523206&w=2
Comment 8 RHEL Product and Program Management 2010-08-09 15:16:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2014-03-07 08:53:04 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 10 RHEL Product and Program Management 2014-06-02 09:21:46 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.