Bug 498909 - Crashed durrin install of preview
Crashed durrin install of preview
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:4adc4a590003c00f5...
:
: 504541 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 08:30 EDT by Andrew Jamison
Modified: 2009-06-08 09:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 10:15:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (231.01 KB, text/plain)
2009-05-04 08:30 EDT, Andrew Jamison
no flags Details

  None (edit)
Description Andrew Jamison 2009-05-04 08:30:23 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 1000, in isExtended
    return self.partType & parted.PARTITION_EXTENDED
  File "/usr/lib/anaconda/storage/devices.py", line 1068, in dependsOn
    if isinstance(dep, PartitionDevice) and dep.isExtended and self.isLogical:
  File "/usr/lib/anaconda/storage/devicetree.py", line 600, in cmpActions
    elif a1.device.dependsOn(a2.device):
  File "/usr/lib/anaconda/storage/devicetree.py", line 647, in processActions
    self._actions.sort(cmp=cmpActions)
  File "/usr/lib/anaconda/storage/__init__.py", line 234, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
TypeError: unsupported operand type(s) for &: 'NoneType' and 'int'
Comment 1 Andrew Jamison 2009-05-04 08:30:56 EDT
Created attachment 342297 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-05-04 10:15:25 EDT
This is fixed in anaconda-11.5.0.48.  Thanks for the bug report.
Comment 3 Chris Lumens 2009-06-08 09:45:57 EDT
*** Bug 504541 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.