Bug 498935 - Unqualified exec not allowed in function "run"
Unqualified exec not allowed in function "run"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.4
i386 Linux
high Severity urgent
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
: 498996 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 10:28 EDT by Martin Sivák
Modified: 2009-09-02 05:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:52:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the traceback (347.62 KB, image/jpeg)
2009-05-04 10:28 EDT, Martin Sivák
no flags Details

  None (edit)
Description Martin Sivák 2009-05-04 10:28:24 EDT
Created attachment 342316 [details]
Screenshot of the traceback

Description of problem:

Version-Release number of selected component (if applicable):

RHEL 5.4 nightly 20090503

How reproducible:

Get to stage 2
  
Actual results:

Traceback

Expected results:

Stage 2 instalation environment
Comment 1 Martin Sivák 2009-05-04 10:30:13 EDT
I've forgotten to mention.. it is NFS based install and I asked for text mode on the kernel cmdline.
Comment 2 Chris Lumens 2009-05-04 14:26:09 EDT
*** Bug 498996 has been marked as a duplicate of this bug. ***
Comment 3 Hans de Goede 2009-05-05 02:38:23 EDT
Using 5.4 4-29 nightly and an updates.img with all .py files the 5.3 final
anaconda in there, the 'Unqualified exec not allowed in function "run"'
error goes away. Bisecting pinpoints the cause to the following commit:
"Ignore a subset of parted errors that are not critical (#455465).":
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff_plain;h=c4c13840cdf3d6127ea1f22b8d14b1360b301f87

I can confirm that reverting this commit (and the typo fix commit for it),
fixes this. Chris, that commit is yours so I'm assigning this to you.
Comment 4 Chris Lumens 2009-05-05 10:07:12 EDT
This should be fixed in anaconda-11.1.2.172-1.
Comment 5 RHEL Product and Program Management 2009-05-05 10:10:37 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Brock Organ 2009-05-11 15:53:34 EDT
unfortunately RHEL5.4-Server-20090511.nightly does not fix this issue ... (using anaconda-11.1.2.172-1.s390x ) ...
Comment 9 Brock Organ 2009-05-11 15:55:27 EDT
i apologize I was incorrect, comment #8 should've been made against bug 498992, not this bug ... changing this bug's status back ...
Comment 10 Brock Organ 2009-05-11 16:03:31 EDT
verified fix in RHEL5.4-Server-20090511.nightly using anaconda-11.1.2.172-1 on x86_64 ...
Comment 12 errata-xmlrpc 2009-09-02 05:52:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1306.html

Note You need to log in before you can comment on or make changes to this bug.