Bug 498970 - menu redraw in xmms extremely slow
menu redraw in xmms extremely slow
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 11:55 EDT by Konrad Karl
Modified: 2009-05-11 04:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 17:53:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konrad Karl 2009-05-04 11:55:07 EDT
e.g redrawing the preferences menu takes about three seconds here.

00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965
current rawhide x86_64. (ok,intel driver is one build behind because
of https://bugzilla.redhat.com/show_bug.cgi?id=496614)

on the same hardware F10 redraws in normal speed.
Comment 1 Adam Jackson 2009-05-04 19:09:21 EDT
Unable to reproduce on i386.  Exactly what kernel and driver builds are you running?
Comment 2 Konrad Karl 2009-05-05 15:01:30 EDT
Ok, with xorg-x11-drv-intel-devel-2.6.0-14.fc11.x86_64.rpm 
menu redraw is normal speed. 

(uptodate rawhide with todays kernel-2.6.29.2-126.fc11.x86_64)

I am suffering from hangs with the intel driver when playing
a movie in mplayer (already bz'ed). The last non-hanging driver
for me is xorg-x11-drv-intel-2.6.0-14.fc11.x86_64 and with that
xmms menu update is slow.

waiting for a fixed intel driver.....
Comment 3 Adam Jackson 2009-05-08 17:53:31 EDT
Core text performance (which is almost certainly your xmms performance problem) has been fixed since 2.6.0-14 and accompanying kernel and libdrm updates.
Comment 4 Konrad Karl 2009-05-11 04:50:29 EDT
ouch, copy and paste error...
kernel-2.6.29.2-126 + xorg-x11-drv-intel-2.7.0-4 renders
the xmms menu fast but crashes with mplayer/xine and friends.

kernel-2.6.29.2-126 + xorg-x11-drv-intel-2.6.0-14 renders the xmms menu slow.
(i am not sure if i should interpret "has been fixed since 2.6.0-14" as
"2.6.0-14 should already be fine" though)
Konrad

Note You need to log in before you can comment on or make changes to this bug.