Bug 499028 - My "last search" is stuck
My "last search" is stuck
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.2
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 16:44 EDT by Göran Uddeborg
Modified: 2013-06-23 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 15:48:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2009-05-04 16:44:43 EDT
If I do a search, and select one of the bugs I find, Bugzilla says the bug is not in my list.  And if I click on "show last search result" I get the results from an old search.  (It looks as if I searched for selinux and kismet, which I may very well have done.  But it must be many months ago now, I do not know how many.)
Comment 1 David Lawrence 2009-05-05 10:22:55 EDT
Question: does the search results where you click on a bug id from say that the list of was "too long"? When the list is over 400 long, Bugzilla does not set a cookie that contains all of the bug ids in a colon delimited list. Under normal circumstances when the list is less than 400, Bugzilla will use this cookie on the show_bug.cgi page to allow you to get back your previous search results or advance to the next bug in the list. So if you results were too long, you get the bug is not in your list message when viewing a bug as the cookie that it sees is from other previous search. Is this the case maybe?

Dave
Comment 2 Göran Uddeborg 2009-05-05 12:17:27 EDT
I would have been surprised if all my searches in that long time had resulted in more than 400 hits.  But just to be sure I made a search for all bugs with the words "last" and "search" in the summary.  It returned 15 hits (including this bug, obviously).

I clicked on one in the middle.  But it was still not in the list.  And when I looked at last search results it was still the same as in comment 0.

Since you mentioned this is stored in cookies, I took a look at the cookies I had stored for bugzilla.redhat.com.  I found three cookies named "BUGLIST".  (I didn't know one could have more than one cookie from one domain with the same name.  You learn something every day!)  The first of them contains the list that comes up each time.  None of them contained the list from the search I just did.

Should I clean up my cookie list from bugzilla.redhat.com and see what happens?  Or do we want to keep them for debugging?
Comment 3 David Lawrence 2009-05-05 14:06:26 EDT
(In reply to comment #2)
> Should I clean up my cookie list from bugzilla.redhat.com and see what happens?
>  Or do we want to keep them for debugging?  

I would definitely suggest trying to clear out the duplicate cookies. I have seen in rare circumstances cookies get "stuck" and not allow new ones to be set for whatever reason. If you clear it out, try to do another search and see if this time the results are saved.

Dave
Comment 4 Göran Uddeborg 2009-05-05 15:34:08 EDT
That helped!  I guess we don't really know what was wrong, but the problem is gone.  Thanks for the suggestion!
Comment 5 David Lawrence 2009-05-05 15:48:30 EDT
(In reply to comment #4)
> That helped!  I guess we don't really know what was wrong, but the problem is
> gone.  Thanks for the suggestion!  

Glad it helped.

Note You need to log in before you can comment on or make changes to this bug.