Bug 499046 - Need tooltip and upgrade path for %post/%pre scripts edit page
Need tooltip and upgrade path for %post/%pre scripts edit page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Sherrill
Pradeep Kilambi
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-05-04 19:09 EDT by Mike McCune
Modified: 2009-09-10 15:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:25:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2009-05-04 19:09:53 EDT
Because existing kickstart pre and post scripts may contain $variables that are not going to resolve when cobbler renders the profiles we need to pre and postpend the following during the upgrade of Satellite 5.2 -> 5.3:

#raw
.. existing script ..
#end raw

this will ensure compatibility.

Also need a tooltip on the kickstart script create/edit page noting that if you have $variables that are not associated with the profile you need to wrap them with #raw and #end raw
Comment 1 Justin Sherrill 2009-05-05 15:37:33 EDT
b668fba 

so i added a 'template' option to the scripts edit/create page that is disabled by default.  If it's disabled  

#raw
& #end raw  

are added to the script
Comment 3 John Matthews 2009-07-29 16:14:24 EDT
Moving to RELEASE_PENDING

Verified that "template" option checkbox controls the inserts of "#raw    #end raw" by looking at a kickstart file under /var/lib/rhn/kickstarts/wizard

#raw
%post --interpreter testscript01
$TEMP_VALUE
#end raw
Comment 4 Brandon Perkins 2009-09-10 15:25:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.