Bug 499053 - "43.7.5. IPsec Installation" - racoon daemon path might be wrong
"43.7.5. IPsec Installation" - racoon daemon path might be wrong
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide (Show other bugs)
5.5
All Linux
low Severity medium
: alpha
: ---
Assigned To: Douglas Silas
Joshua Wulf
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 20:22 EDT by Murray McAllister
Modified: 2016-06-17 17:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-25 17:19:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Murray McAllister 2009-05-04 20:22:29 EDT
Description of problem:
<http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Deployment_Guide/s1-ipsec-generalconf.html>, second point says "/sbin/racoon — the IKE key management...". 

I checked on two Red Hat Enterprise Linux 5.3 machines, and they both used "/usr/sbin/racoon".

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
$ /sbin/racoon
bash: /sbin/racoon: No such file or directory

Expected results:
/usr/sbin/racoon

Additional info:
Not sure what the case is on Red Hat Enterprise Linux 4, or Red Hat Enterprise Linux 5 prior to 5.3.
Comment 1 Murray McAllister 2009-05-04 20:24:29 EDT
ipsec-tools-0.6.5-13.el5
Comment 2 Andrew Ross 2009-05-04 20:32:48 EDT
Same on RHEL5 Server:

/usr/sbin/racoon

think you've got yourself a typo there mmcallis :D
Comment 4 RHEL Product and Program Management 2009-07-28 19:09:11 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 8 Douglas Silas 2009-09-02 19:04:09 EDT
Tomas,

I am asking you because you are listed as the maintainer of ipsec-tools: do you know whether the path for racoon has been /usr/sbin/racoon since RHEL 5.0, or if it has changed between releases?

Thanks,

Silas
Comment 9 Tomas Mraz 2009-09-03 07:28:16 EDT
The path for racoon was always /usr/sbin/racoon (in RHEL-5.0 as well as in RHEL-4).
Comment 10 Douglas Silas 2009-09-03 14:55:06 EDT
Fixed in -r 21655, 5.4. Setting to MODIFIED.
Comment 11 Douglas Silas 2009-09-03 14:55:39 EDT
Thanks Tomas for the input :-)
Comment 14 RHEL Product and Program Management 2009-11-06 13:41:42 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 16 Andrew Ross 2009-11-25 17:19:09 EST
Verified: now /sbin/racoon

Closing.

Note You need to log in before you can comment on or make changes to this bug.