Bug 499055 - unable to install sat530 iso on rhel 4u7 xen guest
unable to install sat530 iso on rhel 4u7 xen guest
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-04 21:18 EDT by wes hayutin
Modified: 2009-05-13 17:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 17:58:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spacewalk-debug (738.13 KB, application/octet-stream)
2009-05-04 21:19 EDT, wes hayutin
no flags Details
tail end of an strace of oraclerhnsat process. (4.04 KB, text/plain)
2009-05-05 13:06 EDT, Devan Goodwin
no flags Details

  None (edit)
Description wes hayutin 2009-05-04 21:18:03 EDT
Description of problem:
recreate:
1. register a rhel 4u7 xen guest to hosted
2. run install, I think some u8 packages are picked up, and throwing off the install
3. up2date -u the box to rhel4u8

Satellite-5.3.0-RHEL4-re20090501.1-i386-embedded-oracle.iso

The same build works on a fresh install of rhel 4u7 server non virt.


SQL> SQL>   2    3    4    5    6    7    8    9   10   11   12   13   14   15   16   17   18   19   20   21   22   23   24   25   26   27   28   29   30   31   32   33   34   35  
Database created.

SQL> SQL> select sysdate, 'Creating tablespace users' message from dual
                                                         *
ERROR at line 1:
ORA-00600: internal error code, arguments: [15160], [], [], [], [], [], [], []


Disconnected from Oracle Database 10g Enterprise Edition Release 10.2.0.4.0 - Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options
[root@dhcp77-141 ~]# 


attaching rhn-debug and sosreport
Comment 1 wes hayutin 2009-05-04 21:19:58 EDT
Created attachment 342399 [details]
spacewalk-debug
Comment 2 wes hayutin 2009-05-05 10:13:22 EDT
fyi.. this is on a xen guest... also recreated on rhel4U7 so I'm not really sure whats going on here.  The only variable is that this install was on a xen guest.
Comment 3 Devan Goodwin 2009-05-05 10:43:01 EDT
Couldn't reproduce this in a Xen guest on test13-64. Registered to hosted and updated, even unblocked the kernel packages and updated those. 

Satellite install completed normally.

Did this happen more than once to you? Any additional details you can think of? (which host, etc?)

The error is supposedly caused by a complicated join the Oracle can't deal with, which makes no sense as we're using the same Oracle versions and it's normally fine. Also the query in your output just before the error doesn't look terribly obscure to me:
Comment 4 Devan Goodwin 2009-05-05 10:52:55 EDT
From IRC convo with Wes, this bug has been encountered three times, always on the same Xen host, and with guests running el4u7 and el4u8. This Xen host has been used and working fine for about three months, most recently the Apr 24 ISO installed fine.
Comment 5 Brandon Perkins 2009-05-05 12:32:51 EDT
Jan and Michael, can you both take a look and see if anything pops-out at you about this one.
Comment 6 Devan Goodwin 2009-05-05 13:06:51 EDT
Created attachment 342495 [details]
tail end of an strace of oraclerhnsat process.

Adding the tail end of the strace output of the oraclerhnsat process running during the database installation.
Comment 8 Michael Mráka 2009-05-06 05:40:27 EDT
I've never seen this error on any of our xen guests. If it's reproducible only on one host/guest I'd blame hardware (memory/disk).
Comment 9 wes hayutin 2009-05-06 08:43:15 EDT
anyone have another machine I can reproduce on?
Comment 10 Petr Sklenar 2009-05-11 13:07:19 EDT
Hello,
I can reproduced similar behaviour on xen with rhel48 too, but it writes another error:
Bug 500205 -  cannot complete installation of satellite-5.3 on xen guest rhel4
Comment 11 Jan Pazdziora 2009-05-12 11:15:37 EDT
(In reply to comment #10)
> Hello,
> I can reproduced similar behaviour on xen with rhel48 too, but it writes
> another error:
> Bug 500205 -  cannot complete installation of satellite-5.3 on xen guest rhel4  

Note: that one is caused by the machine being x86_64. And I believe that you would be able to get the problem from bug 500205 even on physical hardware.
Comment 12 Jan Pazdziora 2009-05-12 11:17:08 EDT
I'm affraid that even if the bugzilla is currently assigned to me, I really do not have any clue how to proceed.

(In reply to comment #2)
> fyi.. this is on a xen guest... also recreated on rhel4U7 so I'm not really
> sure whats going on here.  The only variable is that this install was on a xen
> guest.  

Wes, do you have that reproducer Xen guest machine around?
Comment 14 wes hayutin 2009-05-12 12:49:40 EDT
agreed, looking for hardware..
I have a request in to use test02-vmx.rhndev
Comment 15 wes hayutin 2009-05-12 17:58:01 EDT
finally verified its working fine on another system..
closing
5/7.1 build

Note You need to log in before you can comment on or make changes to this bug.