This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 499083 - ldd doesn't work?
ldd doesn't work?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 02:56 EDT by Edouard Bourguignon
Modified: 2009-05-05 02:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 02:59:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edouard Bourguignon 2009-05-05 02:56:04 EDT
Description of problem:
ldd doesn't seem to work on rawhide, it can't recognize a file to be a shared object dynamicaly linked.

Version-Release number of selected component (if applicable):
glibc-common-2.9.90-22.x86_64

How reproducible:
seems static

Steps to Reproduce:
1. grab a library file (I try on SweetHome3D)
2. $ ldd lib/libj3dcore-ogl.so
ldd: warning: you do not have execution permission for `lib/libj3dcore-ogl.so'
	not a dynamic executable
3. $ file lib/libj3dcore-ogl.so 
lib/libj3dcore-ogl.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped
  
Actual results:
doesn't show the shared libraries used by this file.


Expected results:
should print the shared libraries

Additional info:
This was working fine on F10:
$ ldd lib/libj3dcore-ogl.so
ldd: warning: you do not have execution permission for `lib/libj3dcore-ogl.so'
    linux-gate.so.1 =>  (0x00689000)
    libdl.so.2 => /lib/libdl.so.2 (0x00300000)
    libGL.so.1 => /usr/lib/libGL.so.1 (0x00891000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0x003f9000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0x00af3000)
    libm.so.6 => /lib/libm.so.6 (0x00e3d000)
    libnsl.so.1 => /lib/libnsl.so.1 (0x00357000)
    libc.so.6 => /lib/libc.so.6 (0x00c03000)
    /lib/ld-linux.so.2 (0x00aac000)
    libjawt.so => not found
    libjvm.so => not found
    libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0x00110000)
    libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x0018e000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00115000)
    libdrm.so.2 => /usr/lib/libdrm.so.2 (0x0069d000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x0019e000)
    libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x00f6c000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0x0011a000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0x00f77000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00f98000)
Comment 1 Edouard Bourguignon 2009-05-05 02:59:07 EDT
Sorry I find out that I have to install glibc.i686. So it's not a bug.

Note You need to log in before you can comment on or make changes to this bug.