Bug 499085 - Can't fetch https:// through proxy
Can't fetch https:// through proxy
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 493805 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 03:08 EDT by Stefan Becker
Modified: 2010-06-28 08:22 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-13.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:22:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Becker 2009-05-05 03:08:25 EDT
Description of problem:

When behind a firewall anaconda fails after a while trying to fetch the repository information and then offers to configure a proxy (Why doesn't it offer this option beforehand BTW???)

The dialog shows that it tries to fetch

    <https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=...>

But anaconda CAN'T fetch https: through a proxy. After changing https: to http: the install continued fine.

Version-Release number of selected component (if applicable):
anaconda 11.5.0.48

How reproducible:
Tried several times during the same install with different proxy URLs.

Additional info:

* Proxy dialog is confusing. Label says "Proxy URL" (i.e. you need to enter full URL http://...) but then says "(hostname:port)". hostname:port ARE not accepted, only full URLs.

* While checking for the cause we also tested "wget" on the command line. wget is ALSO not able to fetch https:// through the proxy. So I guess the root cause might be that some SSL module for Perl/Python is missing.
Comment 1 Bug Zapper 2009-06-09 11:09:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Andy Lindeberg 2009-08-04 15:32:34 EDT
*** Bug 493805 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-09-30 13:41:18 EDT
This should finally (finally!) be fixed in the next build of anaconda for F13.  It won't be fixed in F12, and probably has a couple other bugs as well, but as soon as we start doing rawhide composes pulling from F13, it should be testable.
Comment 4 Mike Hanafey 2009-10-09 09:04:53 EDT
This issue refers to anaconda, but just wanted to clarify that the same problem exists after a system is installed, and "yum upgrade" is run from the command line.

With a proxy, the following sequence always fails:

yum clean all
yum update
Loaded plugins: refresh-packagekit
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again

I tried with two proxies, one returns status 400 (Bad Request), and the other (squid) returns 501 (Not Implemented) to the "GET https://mirrors.fedoraproject.org/metalink?repo=fedora-11&arch=x86_64 HTTP/1.1" request.
Comment 5 Bug Zapper 2010-04-27 10:07:41 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2010-06-28 08:22:13 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.