Bug 499097 - Python thread may hang during subprocess
Python thread may hang during subprocess
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python (Show other bugs)
5.4
All Linux
low Severity high
: rc
: ---
Assigned To: James Antill
BaseOS QE
:
: 503331 (view as bug list)
Depends On:
Blocks: 497083 499095
  Show dependency treegraph
 
Reported: 2009-05-05 03:49 EDT by Shahar Frank
Modified: 2013-04-12 12:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 08:03:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shahar Frank 2009-05-05 03:49:15 EDT
Description of problem:


subprocess may hit a deadlock if another thread is doing import at the same
time.

see http://bugs.python.org/issue5912 for details.


In most cases this bug occur at the system startup. Theoretically it can happen
any time because there are function level imports.

An easy work arround is to avoid function level imports in the subprocess path
(in the subprocess implementation).
Comment 1 RHEL Product and Program Management 2009-05-05 04:08:04 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 Alan Pevec 2009-06-09 10:39:03 EDT
*** Bug 503331 has been marked as a duplicate of this bug. ***
Comment 8 errata-xmlrpc 2009-09-02 08:03:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1402.html

Note You need to log in before you can comment on or make changes to this bug.