Bug 49919 - kernel source broken
Summary: kernel source broken
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-25 05:47 UTC by Chris Ricker
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 22:33:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump of compile of modules for 2.4.6-3.1 (55.69 KB, text/plain)
2001-07-25 14:44 UTC, Chris Ricker
no flags Details
config file attempting to use with 2.4.6-2 and 2.4.6-3.1 (18.80 KB, text/plain)
2001-07-25 14:45 UTC, Chris Ricker
no flags Details

Description Chris Ricker 2001-07-25 05:47:55 UTC
the kernel source rpm included in the kernel source rpm in beta2 is
extremely borked.  Attempting to compile a custom kernel from it fails in
many places because several options in it have been broken to not compile
as modules (floppy, ramdisk, etc.)

Ideally, these need to be fixed to compile as modules.  Barring that, they
need to be fixed to not allow modular compile as an option.

Comment 1 Chris Ricker 2001-07-25 14:43:24 UTC
This is still true with kernel-source-2.4.6-3.1; lots of stuff can be configured
as a module, but will only compile monolithic.

Comment 2 Chris Ricker 2001-07-25 14:44:42 UTC
Created attachment 24907 [details]
dump of compile of modules for 2.4.6-3.1

Comment 3 Chris Ricker 2001-07-25 14:45:52 UTC
Created attachment 24908 [details]
config file attempting to use with 2.4.6-2 and 2.4.6-3.1

Comment 4 Glen Foster 2001-07-25 22:33:25 UTC
Did you run "make mrproper" before starting the build?

Comment 5 Chris Ricker 2001-07-26 14:12:11 UTC
I'm a moron!  Sorry, I thought I'd remembered to do that, but apparently not....

I'm closing this.


Note You need to log in before you can comment on or make changes to this bug.