Bug 499196 - oracle probes needs to be updated with the correct path for catalog.sql in the Probe Requirements field.
oracle probes needs to be updated with the correct path for catalog.sql in th...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Preethi Thomas
:
Depends On:
Blocks: 463877
  Show dependency treegraph
 
Reported: 2009-05-05 11:13 EDT by Preethi Thomas
Modified: 2009-05-07 00:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 04:52:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-05-05 11:13:32 EDT
Description of problem:
oracle probes needs to be updated with the correct path for catalog.sql in the Probe Requirements field.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL4-re20090501.1-i386-embedded-oracle.iso

How reproducible:


Steps to Reproduce:
1.enable monitoring on the satellite .
2. register a client with oracle running (i registered another sat)
2.create an oracle probe.
3. check the Probe Requirement.
  
Actual results:

Probe Requirements  	Oracle checks require the configuration of the database and public associations made by running $ORACLE_HOME/rdbms/admin/catalog.sql. In addition, in any instance of Oracle, the Oracle user configured in the check must have minimum privileges of CONNECT and SELECT_CATALOG_ROLE.

Expected results:
[root@fjs-0-13 ~]# locate catalog.sql
 /opt/apps/oracle/web/product/10.2.0/db_1/rdbms/admin/catalog.sql


Additional info:
Comment 1 Miroslav Suchý 2009-05-06 04:52:14 EDT
This is not a bug.
You probably tried to access ORACLE_HOME under instant client enviroment:
[root@xen30 ~]# echo $ORACLE_HOME
/usr/lib/oracle/10.2.0.4/client
And then indeed:
[root@xen30 ~]# ls $ORACLE_HOME/rdbms/admin/catalog.sql
ls: /usr/lib/oracle/10.2.0.4/client/rdbms/admin/catalog.sql: No such file or directory
But if you swithc to oracle user (and oracle db enviroment):
[root@xen30 ~]# su - oracle
-bash-3.2$ echo $ORACLE_HOME
/opt/apps/oracle/web/product/10.2.0/db_1
-bash-3.2$ ls  $ORACLE_HOME/rdbms/admin/catalog.sql
/opt/apps/oracle/web/product/10.2.0/db_1/rdbms/admin/catalog.sql
Then the path is correct.

Note You need to log in before you can comment on or make changes to this bug.