Bug 499213 - Keyboard selection on GDM login screen is ignored in F11 Preview
Keyboard selection on GDM login screen is ignored in F11 Preview
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 12:03 EDT by J Gallagher
Modified: 2015-01-14 18:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 07:25:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J Gallagher 2009-05-05 12:03:43 EDT
Description of problem:
I selected UK keyboard on gdm login screen, when logged in to Gnome I have a usa keyboard

Version-Release number of selected component (if applicable):
gdm-2.26.1-4.fc11.i586


How reproducible:

Every time I log in to F11 Preview (fully updated from rawhide)


Steps to Reproduce:

1. Install F11 Live DVD i386
2. Select UK keyboard at login screen
3. Login to gnome.
  
Actual results:

I get a US keyboard map (shift + 3 gives me '#' etc)

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "", "terminate:ctrl_alt_bksp"
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "us", "", "terminate:ctrl_alt_bksp"



Expected results:

I expected a UK keyboard


Additional info:

I can add the keyboard selector applet to the gnome panel and change it, or type 'setxkbmap gb'

The language setting is set correctly, I do have the expected en_GB locale.
Comment 1 Matthias Clasen 2009-05-05 16:58:51 EDT
Can you try updating to gdm-2.26.1-7.fc11, 
gnome-settings-daemon-2.26.1-4.fc11 and 
control-center-2.26.0-6.fc11, and see if the problem goes away ?
Comment 2 J Gallagher 2009-05-05 18:21:30 EDT
Applying those 3 updates (from koji) and the dependency control-centre-filsystem-2.26.0-6.fc11.i586.rpm fixes the issue for me. Keyboard selection at gdm login now applies in Gnome desktop as expected.

Thanks.
Comment 3 Matthias Clasen 2009-05-05 19:25:20 EDT
I'm relieved to hear that. Those builds will be in the next snapshot.
Comment 4 J Gallagher 2009-05-09 17:44:19 EDT
Sorry to say thsi problem is not fixed. The package versions are the latest from rawhide as listed above.

I mistakenly believed this was fixed because in my gnome session I have the keyboard indicator applet and I had deleted the USA keyboard as an option and only left Gbr. After removing the applet the problem returns, and I still get a USA keyboard in Gnome despite selecting a UK one in the gdm login screen.
Comment 5 Bug Zapper 2009-06-09 11:11:31 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 J Gallagher 2009-06-16 07:25:14 EDT
This is fixed in F11 Final

gdm-2.26.1-10.fc11.x86_64
gnome-settings-daemon-2.26.1-5.fc11.x86_64
control-center-2.26.0-6.fc11.x86_64

Note You need to log in before you can comment on or make changes to this bug.