Bug 499227 - Wrong schema file used in %pre script
Wrong schema file used in %pre script
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnote (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 12:53 EDT by Michael Scherer
Modified: 2013-03-13 01:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.3.1-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-09 00:25:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2009-05-05 12:53:14 EDT
It seems that the %re script of the rpm is trying to uninstall gedit schema, not gnote one :

%pre
if [ "$1" -gt 1 ]; then
    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
    gconftool-2 --makefile-uninstall-rule \
      %{_sysconfdir}/gconf/schemas/gedit.schemas > /dev/null || :
fi


http://cvs.fedoraproject.org/viewvc/rpms/gnote/F-11/gnote.spec?revision=1.8&view=markup

I guess this might cause problem on gnote uninstallation.
Comment 1 Rahul Sundaram 2009-05-05 14:30:27 EDT
Ouch. Looks like I copy pasted blindly.  I will fix it in the next update.
Comment 2 Fedora Update System 2009-05-06 00:06:10 EDT
gnote-0.3.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnote-0.3.1-1.fc10
Comment 3 Fedora Update System 2009-05-09 00:25:47 EDT
gnote-0.3.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.