Bug 499251 - fail to detect LVs
fail to detect LVs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 15:44 EDT by Clyde E. Kunkel
Modified: 2009-05-14 18:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 18:32:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage log from rawhide anaconda 11.5.0.47 (206.15 KB, text/plain)
2009-05-05 19:16 EDT, Clyde E. Kunkel
no flags Details
lvscan output from failed storage detection (1.31 KB, text/plain)
2009-05-05 19:17 EDT, Clyde E. Kunkel
no flags Details
storage log from "good" anaconda storage detection (319.19 KB, text/plain)
2009-05-05 19:20 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2009-05-05 15:44:43 EDT
Description of problem:
Anaconda fails to detect pre-existing logical volumes.

Version-Release number of selected component (if applicable):
11.5.0.49
How reproducible:
Every try

Steps to Reproduce:
1. boot.iso, askmethod, use http://download.fedora.etc
2. select custom partitioning
3.
  
Actual results:
Only non-PV partitions shown and thus no VG/LVs


Expected results:
show VG/LVs

Additional info:

regression?
Comment 1 Chris Lumens 2009-05-05 17:40:21 EDT
Please attach /tmp/storage.log to this bug report.  I'm definitely not seeing this behavior here.
Comment 2 Clyde E. Kunkel 2009-05-05 19:16:05 EDT
Created attachment 342555 [details]
storage log from rawhide anaconda 11.5.0.47

As requested.

After see that the Lvs were not detected and after saving storage.log, did a lvscan on tty-2 and saw all LVs.  Attaching as next attachment.  

Noticed that "Finding storage devices" routine did not request encrypted LV partitions' pass phrases and - subjectively - ran in much less time that previous working tests.  Then reran install with F11 x86_64 Preview dvd which does find the LVs.  That storage.log will be attached as the third attachment.
Comment 3 Clyde E. Kunkel 2009-05-05 19:17:15 EDT
Created attachment 342556 [details]
lvscan output from failed storage detection
Comment 4 Clyde E. Kunkel 2009-05-05 19:20:51 EDT
Created attachment 342557 [details]
storage log from "good" anaconda storage detection

Please note that attachment 342555 [details] should read:
342555: storage log from rawhide anaconda 11.5.0.49   
(NOT .47)  sorry for the clumsiness.
Comment 5 Chris Lumens 2009-05-06 16:17:05 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 6 Clyde E. Kunkel 2009-05-07 11:27:47 EDT
Could not definitely test due to 499662, but during storage detection the encrypted LVs were seen.  Just couldn't get to the actual storage layout for custom partitioning.
Comment 7 Clyde E. Kunkel 2009-05-14 14:32:44 EDT
with anaconda .52 LVs now seen in custom partitioning.  

However, could not get past bz 499828, will test more without mounting any luks LVs or parititions.
Comment 8 Clyde E. Kunkel 2009-05-14 18:32:13 EDT
Re-ran without mounting any luks LVs and installed ok.

Note You need to log in before you can comment on or make changes to this bug.