Bug 499258 - System -> Alter Channel Subscriptions generates ISE when changing base channel
System -> Alter Channel Subscriptions generates ISE when changing base channel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Brad Buckingham
John Matthews
: Regression
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-05-05 16:30 EDT by Brad Buckingham
Modified: 2009-09-10 16:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:36:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ISE (18.30 KB, text/plain)
2009-05-05 16:30 EDT, Brad Buckingham
no flags Details

  None (edit)
Description Brad Buckingham 2009-05-05 16:30:38 EDT
Created attachment 342536 [details]
ISE

Description of problem:

When attempting to change the base channel for a system using System -> Alter Channel Subscriptions an ISE is generated.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. clone a RHEL base channel
2. subscribe a system to the RHEL base channel that 1 above was cloned from
3. go to System Details -> Alter Channel Subscriptions
4. select the cloned RHEL base channel (from 1 above)
5. click Confirm
6. click Modify Base Channel Software
  
Actual results:

ISE attached

Expected results:

No ISE and base channel updated as requested.

Additional info:
Comment 1 Brad Buckingham 2009-05-05 16:55:42 EDT
master git commit: 9cb50249fcac767f429f57bfbc2ee64e26305a8b
vader git commit: 7286f0b858feb794a7ba0e1e5964e6047c850b10
Comment 2 Brad Buckingham 2009-05-06 15:38:29 EDT
Found that this same issue occurred if unsubscribing a child channel from the base via Alter Channel Subscriptions.  Since this is related to the same issue, fixing w/this BZ.

master git commit: 3cde5874c387df6c18053486b6c8175e1c4f3075
vader git commit: 0063d5ce400f47ce245c151c7dc33617fd8c9f12
Comment 3 Brad Buckingham 2009-05-20 09:21:00 EDT
Mass move to ON_QA.
Comment 4 John Matthews 2009-05-26 14:06:22 EDT
Verified: ISO Satellite-5.3.0-RHEL5-re20090520.0-i386-embedded-oracle.iso
Comment 5 Preethi Thomas 2009-08-05 14:38:22 EDT
Release Pending
test1182.test.redhat.com
Comment 6 Brandon Perkins 2009-09-10 16:36:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.