Bug 499288 - prism54: no isl3890 firmware
prism54: no isl3890 firmware
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 19:22 EDT by Hubert Figuiere
Modified: 2009-05-11 23:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 08:22:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hubert Figuiere 2009-05-05 19:22:33 EDT
I have a prism54 hard-mac card. When I plug it in I get this in the kernel dmesg:


pcmcia_socket pcmcia_socket0: pccard: CardBus card inserted into slot 0
pci 0000:15:00.0: reg 10 32bit mmio: [0x000000-0x001fff]
pci 0000:15:00.0: supports D1 D2
pci 0000:15:00.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:15:00.0: PME# disabled
prism54 0000:15:00.0: enabling device (0000 -> 0002)
prism54 0000:15:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
eth1 (prism54): not using net_device_ops yet
ath5k phy0: noise floor calibration timeout (5760MHz)
eth1: resetting device...
eth1: uploading firmware...
prism54 0000:15:00.0: firmware: requesting isl3890
prism54: request_firmware() failed for 'isl3890'
eth1: could not upload firmware ('isl3890')
eth1: islpci_reset: failure
eth1: resetting device...
eth1: uploading firmware...
prism54 0000:15:00.0: firmware: requesting isl3890
prism54: request_firmware() failed for 'isl3890'
eth1: could not upload firmware ('isl3890')
eth1: islpci_reset: failure

I couldn't find the package for the isl3890 firmware, albeit the Fine Manual says it should be supported:

http://fedoraproject.org/wiki/F11_User_Guide_-_Connecting_to_the_Internet

The wiki seems to have no other info.

This does not look like bug 447047
Comment 1 John W. Linville 2009-05-06 08:22:18 EDT
The device is supported, if you have the firmware installed.  Unfortunately, we do not have a proper license for distributing the firmware, so you'll have to obtain it on your own.

   http://wireless.kernel.org/en/users/Drivers/p54#firmware

Hth!
Comment 2 Hubert Figuiere 2009-05-11 23:27:09 EDT
Except that the fine manual mentionned in the comment 0 do not mention this and claim that Fedora do have packages for it. Bug is in the documentation then.

Note You need to log in before you can comment on or make changes to this bug.