Bug 499290 - missing proper obsoletes for libdhcp 4/6 client ?
missing proper obsoletes for libdhcp 4/6 client ?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 19:38 EDT by Rahul Sundaram
Modified: 2013-03-13 01:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 14:58:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2009-05-05 19:38:28 EDT
Description of problem:

I used preupgrade to upgrade from Fedora 10 to rawhide. I have the latest Anaconda from yum update and I still find

---

libdhcp4client.i386                12:4.0.0-33.fc10                    installed
libdhcp6client.i386                1.0.22-1.fc10                       installed

---

# rpm -q anaconda

anaconda-11.5.0.49-1.fc11.i586
Comment 1 David Cantrell 2009-05-11 21:40:21 EDT
As of dhcp-4.1.0-20.fc10, it will obsolete libdhcp4client 12:4.0.0-34.fc10 and earlier versions.

libdhcp6client is obsoleted by the dhcpv6-client package.  dhcpv6-1.2.0-2.fc11 and later correctly obsolete libdhcp6client.

I have built these two updates and requested them in F-11 final.  If they are not accepted for F-11 final, I will file updates for each.
Comment 2 David Cantrell 2009-05-12 14:58:06 EDT
Both dhcp-4.1.0-20.fc10 and dhcpv6-1.2.0-2.fc11 have been tagged for inclusion in F-11 final.

Note You need to log in before you can comment on or make changes to this bug.