Bug 499335 - [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
[drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 04:25 EDT by Hin-Tak Leung
Modified: 2009-12-08 17:09 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-20 06:48:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2009-05-06 04:25:45 EDT
Description of problem:

Many such message in dmesg:

[drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4

System otherwise has no ill effect (other than those known and filed separately)

Version-Release number of selected component (if applicable):

kernel-2.6.29.2-129.fc11
xorg-x11-drv-ati-6.12.2-12.fc11

How reproducible:
Always


Steps to Reproduce:
1. Just install the above packages
2. log in and out of gdm a few times
3.
  
Actual results:

messages in dmesg

Expected results:

None such messages.


Additional info:
Comment 1 Eddie Lania 2009-06-06 04:00:03 EDT
May 31 11:38:05 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 12:03:51 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 12:04:06 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 12:04:06 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 12:08:01 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 12:08:16 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 12:08:56 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 12:12:32 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 12:13:00 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 14:51:28 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 14:52:01 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 21:20:16 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
May 31 21:20:59 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  1 08:15:29 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  1 10:45:42 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  1 10:46:13 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  1 17:10:52 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  1 17:11:42 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  2 17:13:59 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  2 17:13:59 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  2 17:13:59 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  2 17:14:36 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  2 19:34:18 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  2 19:34:51 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  3 16:50:01 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  3 16:50:33 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  3 21:41:33 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  3 21:42:02 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  4 16:52:34 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  4 16:53:39 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  4 20:53:16 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  4 20:53:46 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  4 22:16:20 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  5 16:51:24 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  5 22:25:49 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jun  6 09:29:38 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Comment 2 Bug Zapper 2009-06-09 11:14:22 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Vlad 2009-06-17 17:59:01 EDT
ATI Radeon X800XL
2.6.29.4 kernel and 6.12.2-14 ati drivers.

Same messages(but only 4 times):
[drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
[drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
[drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Comment 4 Yul Rottmann 2009-07-21 16:41:17 EDT
The same "problem" with my X700pro:

Jul 21 22:28:02 localhost kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
Jul 21 22:28:02 localhost kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4

$ uname -a
Linux localhost.localdomain 2.6.29.5-191.fc11.x86_64 #1 SMP Tue Jun 16 23:23:21 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux


If you need more information just let me know.
Comment 5 Jérôme Glisse 2009-10-14 07:04:36 EDT
Can you test with fedora 12 livecd and report if it works with it.
Comment 6 Yul Rottmann 2009-10-19 10:35:50 EDT
Seems to be fixed, thanks!
Comment 7 Jérôme Glisse 2009-10-20 06:48:09 EDT
Closing it, reopen if you experience this issue again.
Comment 8 Harshavardhana 2009-11-06 13:22:31 EST
Please reopen this bug, 

same problem re appeared 

kernel-2.6.30.9-90.fc11.x86_64.rpm
xorg-x11-drv-ati-6.12.2-14.fc11.x86_64.rpm
Comment 9 Eddie Lania 2009-11-06 13:48:51 EST
grep -i drm /var/log/messages |grep ERROR
Nov  2 16:48:26 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon
gem set domain -11 failed 0 4
Nov  3 21:06:29 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon
gem set domain -11 failed 0 4
Nov  5 16:50:41 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon
gem set domain -11 failed 0 4
Nov  5 17:04:50 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon
gem set domain -11 failed 0 4
Nov  6 17:00:39 p3000fedora kernel: [drm:radeon_gem_do_relocate] *ERROR* radeon
gem set domain -11 failed 0 4

kernel-PAE-2.6.30.9-90.fc11.i686
xorg-x11-drv-ati-6.12.2-14.fc11.i586
Comment 10 Bertho 2009-11-24 17:55:58 EST
Same problem here. Only, it seems that the system is losing memory after this happens. I've had the OOM killer going amok on the latest kernel (2.6.30.9-96.fc11.i586). Running the previous (2.6.30.9-90.fc11.i586) seems to be better, but I still see the kernel mark memory as used that I cannot account for.
BTW, running xorg-x11-drv-ati-6.12.2-14.fc11.i586 (system fully updated).

It looks like that the memory loss can be forced by using Firefox and the kde PDF reader embedded (ocular: kdegraphics-4.3.2-3.fc11.i586). Otherwise running Gnome though. Especially browsing large PDFs with large embedded images seem to accelerate the problem.

When going from init 5 to init 1 and back to init 5 I'd expect to have recovered all memory that might be wasted, but it is not. My best guess is that the kernel has it marked as still used.

Hardware: IBM Thinkpad T42p with (from lspci) VGA compatible controller: ATI Technologies Inc M10 NT [FireGL Mobility T2] (rev 80).

--
Greetings Bertho
Comment 11 h199526 2009-12-08 14:56:20 EST
Fedora 11 Gnome
kernel 2.6.30.9-99.fc11.i686
Hardware: asus k8v-x MoBo; radeon graphics card.

Often give a 2 or 3 beeps a few secs apart. The whole system then locks up. Reboot seems to clear it temporarily. The problem occurs even if just booted and then left with the screen locked. Problem more frequent if using a browser (firefox or opera).
system log viewer - messages gives
[drm:radeon_gem_do_relocate] *ERROR* radeon gem set domain -11 failed 0 4
then
Kerneloops: Submitted 0 kernel oopses to www.kerneloops.org

I've ordered the Fedora 12 DVD to, hopefully, resolve the problem.
Comment 12 Hin-Tak Leung 2009-12-08 17:09:52 EST
Have not seen it since upgraded to f12.

Note You need to log in before you can comment on or make changes to this bug.