Bug 499364 - setroubleshootd is using a ridiculous amount of memory
setroubleshootd is using a ridiculous amount of memory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 07:23 EDT by James Morris
Modified: 2009-05-06 08:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 08:32:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Morris 2009-05-06 07:23:46 EDT
Description of problem:

# ps -F -C  setroubleshootd
UID        PID  PPID  C    SZ   RSS PSR STIME TTY          TIME CMD
root      1651     1  0 78094 70508   0 14:52 ?        00:00:02 /usr/bin/python -E /usr/sbin/setroubleshootd -f


Version-Release number of selected component (if applicable):

setroubleshoot-2.1.8-1.fc11.x86_64


Additional info:

People might hate SELinux a little less if we can reduce the memory used by this.
Comment 1 Daniel Walsh 2009-05-06 07:53:27 EDT
This is a problem with python.  setroubleshoot should only be running for very short times now.  It shuts down after 10 seconds of the last AVC that arrives.  Unless you are running the browser.

So the problem is with python.
Comment 2 Daniel Walsh 2009-05-06 08:32:26 EDT
Actually there looks like there is a bug, which is preventing setroubleshootd from exiting.  I will fix the bug and it will make setroubleshootd only run when required by an AVC or a user running the GUI.


Fixed in setroubleshootd-2.1.10-1.fc11.x86_64.rpm
Comment 3 Daniel Walsh 2009-05-06 08:44:33 EDT
Also look at

http://illiterat.livejournal.com/4615.html

Note You need to log in before you can comment on or make changes to this bug.